WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [ipw2200] wifi no workee  (Read 4652 times)

lmart

  • Guest
[ipw2200] wifi no workee
« on: July 27, 2010, 09:54:26 AM »
Unable to get wifi working.
1.   Installed the following:
1.1.   wireless_tools.tcz
1.2.   wireless-2.6.29.1-tinycore.tcz
1.3.   wpa-supplicant.tcz (unsure why required)
2.   Created the following script:
2.1.   #!/bin/sh
2.2.   clear
2.3.   #verify the drivers are present and loaded
2.4.   sudo modprobe -l | grep ipw2200
2.5.   sudo lsmod | grep ipw2200
2.6.   #
2.7.   #manually entered data for all ""
2.8.   wlan=""
2.9.   sudo iwconfig ${wlan} ap ""
2.10.   sudo iwconfig ${wlan} essid ""
2.11.   sudo iwconfig ${wlan} mode Managed
2.12.   sudo iwconfig ${wlan} key ""
2.13.   sudo udhcpc -i ${wlan}
3.   Drivers are present and loaded.   Tried wlan0 and eth1 as values for “wlan”.  Nothing seems to work.

Thoughts?  Prefer getting wifi working from the CLI, then will move to a GUI based app.  Thx.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: [ipw2200] wifi no workee
« Reply #1 on: July 27, 2010, 10:09:47 AM »
I also have ipw2200, and it requires firmware, below is what I use:

http://ipw2200.sourceforge.net/firmware.php

That firmware must be installed before the main ipw2200 kernel module is loaded.  I make a firmware extension to accomplish that, placing it ahead of the wireless-(kernel)-tinyocore.tcz extension in onboot.lst.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: [ipw2200] wifi no workee
« Reply #2 on: July 27, 2010, 12:49:04 PM »
Unable to get wifi working.
1.3.   wpa-supplicant.tcz (unsure why required)
redundant unless WPA is required.
Quote
2.4.   sudo modprobe -l | grep ipw2200
Huh?  :o and what would "-l" do? Doesn't appear to be documented...
Quote
2.5.   sudo lsmod | grep ipw2200
Why use sudo for lsmod? Not that it could do any harm in this place, but let's not overdo it  :P
Quote
Thoughts?  Prefer getting wifi working from the CLI, then will move to a GUI based app.  Thx.
I'd prefer getting everything working with manual commands first (step by step) and *then* to script it ;)
Having <tail -f /var/log/messages> (after having syslogd started) run on a terminal might potentially be of benefit  ;)
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: wifi no workee
« Reply #3 on: July 27, 2010, 04:09:21 PM »
Quote
2.4.   sudo modprobe -l | grep ipw2200
Huh?  :o and what would "-l" do? Doesn't appear to be documented...
Not to get OT here.. but if you do look at the relevant documentation again, it's there.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: [ipw2200] wifi no workee
« Reply #4 on: July 27, 2010, 05:08:53 PM »
Umm, I did look at the relevant documentation again as you suggested:
Code: [Select]
modprobe [-knqrsv] MODULE [symbol=value ...]
source: http://linux.die.net/man/1/busybox  ???
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: [ipw2200] wifi no workee
« Reply #5 on: July 28, 2010, 02:23:52 AM »
Evidently the linux.die.net page is somewhat dated.

Code: [Select]
tc@box:~$ modprobe --help
BusyBox v1.17.0 (2010-07-10 11:41:42 EEST) multi-call binary.

Usage: modprobe [-alrqvsb] MODULE [symbol=value]...

Options:
        -a      Load multiple MODULEs
        -l      List (MODULE is a pattern)
        -r      Remove MODULE (stacks) or do autoclean
        -q      Quiet
        -v      Verbose
        -s      Log to syslog
        -b      Apply blacklist to module names too

tc@box:~$


« Last Edit: July 28, 2010, 02:26:13 AM by Jason W »

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: [ipw2200] wifi no workee
« Reply #6 on: July 28, 2010, 03:25:38 AM »
Evidently matching my busybox in datedness too:  :o
Code: [Select]
tc@box:~$ modprobe --help
BusyBox v1.14.3 (2009-11-14 10:19:18 PST) multi-call binary

Usage: modprobe [-knqrsv] MODULE [symbol=value...]

Options:
        -n      Dry run
        -q      Quiet
        -r      Remove module (stacks) or do autoclean
        -s      Report via syslog instead of stderr
        -v      Verbose
        -b      Apply blacklist to module names too
That's why with all the multiple cross checking it would never have occurred to me...  :-\
What had occurred to me was that OP might reference modprobe from module-init-tools.tcz, but then as he is very detailed in what he did step by step I kind of ruled that out.
Thanks for pointing that out and apologies for the created confusion.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: [ipw2200] wifi no workee
« Reply #7 on: July 28, 2010, 05:53:02 AM »
#2 I noticed on boot, certain messages about not loading firmware.  Apparently, this is the reason JasonW suggested the ipw2200 firmware.  Does tinycore retain the boot messages in a file that I can access and, if so, where is it filed?

You can see boot messages and more using the command "dmesg". Using the command alone will result in a very long list, so you can also use:

"dmesg | tail -n" where n is the last n lines - 10 or 20 is usually a good number
"dmesg | grep something" where something could be "firmware" in your case

Edit: If you'd like to put the contents of dmesg in a file, you can use "dmesg > myfilename"
« Last Edit: July 28, 2010, 05:54:47 AM by Juanito »

Offline 3rail

  • Full Member
  • ***
  • Posts: 114
Re: [ipw2200] wifi no workee
« Reply #8 on: July 28, 2010, 05:54:13 AM »
@lmart, what I had to do get ipw2200 working is documented in this thread:

http://forum.tinycorelinux.net/index.php?topic=377.0

good luck

3rail

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: [ipw2200] wifi no workee
« Reply #9 on: July 28, 2010, 09:23:57 AM »
It appears that my post prompted an interesting side discussion.  A good learning experience.

A quick comment on sudo.  My original script did not have sudo on each line.  Nothing worked, so I fronted each command with sudo.  Again, as nothing worked, I simply posted the most recent script.
Ah, now i can understand that. That's why i continue to suggest to proceed with manual commands step by step until it works before  bothering with editing scripts, way easier and less time consuming.

Altenatively/additionally to using dmesg you can also boot with option "syslog" which will log to /var/log/messages. I am not exactly sure which are all the exact differences between dmesg and syslog, but looking at both in need couldn't harm.
« Last Edit: July 28, 2010, 09:31:02 AM by tinypoodle »
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10992
Re: [ipw2200] wifi no workee
« Reply #10 on: July 28, 2010, 10:29:09 AM »
Syslogd logs everything sent for logging (daemon output, sudo...), dmesg only kernel output.
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: [ipw2200] wifi no workee
« Reply #11 on: July 29, 2010, 05:46:44 AM »
I think I just grabbed the latest version on that page, but upon looking in the 2.6.33.3 kernel source the included driver is at version 1.2.2.  So the latest one would be correct.

Offline 3rail

  • Full Member
  • ***
  • Posts: 114
Re: [ipw2200] wifi no workee
« Reply #12 on: July 29, 2010, 06:50:48 AM »
@lmart please read the whole thread at http://forum.tinycorelinux.net/index.php?topic=377.0 since there are revisions to the original steps towards the end of the topic

gl