WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Alsamixer starts turned off.  (Read 7080 times)

Offline alanl

  • Newbie
  • *
  • Posts: 48
Alsamixer starts turned off.
« on: September 19, 2009, 07:47:26 PM »
I run alsamixer and set it up.  I run alsactl store.  asound.state shows
up in /etc.  I add etc/asound.state to /opt/filetool.list.  When I boot up
alsamixer is set to off.  The asound.state file is in /etc.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: Alsamixer starts turned off.
« Reply #1 on: September 19, 2009, 08:26:48 PM »
It works fine here.

But I see the same behavior when I do not run "/usr/local/etc/init.d/alsasound start" after rebooting.  Running that would most likely result in restored volume settings.

Offline alanl

  • Newbie
  • *
  • Posts: 48
Re: Alsamixer starts turned off.
« Reply #2 on: September 19, 2009, 08:45:00 PM »
I have that in /opt/bootlocal.sh.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: Alsamixer starts turned off.
« Reply #3 on: September 19, 2009, 09:26:06 PM »
Try removing it or commenting it out of bootlocal.sh and waiting until the desktop is up and see if running it then will help.  I one time had an issue like that on one of my machines.

Offline alanl

  • Newbie
  • *
  • Posts: 48
Re: Alsamixer starts turned off.
« Reply #4 on: September 20, 2009, 08:25:38 PM »
I commented it out and on reboot went to /usr/locat/etc/init.d
and ran alsasound start.   
bin/sh: alsasound: not found!  Alsasound was starting before.
It worked fine with tc-143. Now with tc-2.2 - problems.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14572
Re: Alsamixer starts turned off.
« Reply #5 on: September 20, 2009, 10:47:27 PM »
Do you have the latest version of the alsa extension(s) - I believe they were updated several times?

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: Alsamixer starts turned off.
« Reply #6 on: September 21, 2009, 12:08:04 AM »
Also, if in the /usr/local/etc/init.d directory use the command "./alsasound start".  Or use the full path "/usr/local/etc/init.d/alsasound start".

Offline alanl

  • Newbie
  • *
  • Posts: 48
Re: Alsamixer starts turned off.
« Reply #7 on: September 21, 2009, 08:11:03 PM »
Now I ran it with the full path and it worked.
Checked alsamixer and it was set up correctly.
So what`s happening?  Is alsasound getting setup
before asound.state is added to /etc?
I`m going to re-install the alsa tces.

Offline neonix

  • Sr. Member
  • ****
  • Posts: 330
Re: Alsamixer starts turned off.
« Reply #8 on: September 23, 2009, 01:56:54 PM »
I have that in /opt/bootlocal.sh.

You can try add
Quote
sleep 4
alsactl restore

to your /opt/bootlocal.sh

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: Alsamixer starts turned off.
« Reply #9 on: September 23, 2009, 03:09:34 PM »
I use the tcz version of alsa and it is loaded automatically, only
alsactl restore
in bootlocal
dCore user

Offline sci_fi

  • Jr. Member
  • **
  • Posts: 86
Re: Alsamixer starts turned off.
« Reply #10 on: September 25, 2009, 07:17:55 PM »
Wow. Same person. Sorry to trouble you yet again. I really am working hard at this.

I have gotten alsa to support my mic. Testing with arecord and aplay works fine.

However, alsasound start will not automatically configure my mic correctly; hence I need to configure manually and then save and restore.


I am having trouble saving and restoring the configuration.

I thought from reading this thread that what I need to do is:

Save/restore asound.state  via filetool.list
Run alsactl restore or /usr/local/etc/init.d/alsasound start via bootlocal.sh at re-boot.

Problems:

I could not find  a file: /etc/asound.state as described. I tried saving with filetool.list anyway but no joy. Perhaps the alsa config file is someplace else. I poked around but could not find it.

Probably because of the asound.state problem, alsactl restore fails. alsasound start brings up alsa but without my configuration.

Can you advise me?

Thanks yet again.

As soon as I get this working I can try out the skype module.

sci_fi
 

Offline alanl

  • Newbie
  • *
  • Posts: 48
Re: Alsamixer starts turned off.
« Reply #11 on: September 25, 2009, 07:56:29 PM »
a: You need to run alsamixer and set it up as you want.
    Then run alsactl store and the file...asound.state
    will appear in /etc.

b:  I tried all the suggestions and no luck.  I added alsactl restore
     to /opt/bootlocal.sh.  No workee.  Then I added sleep 4 and
     now it works!  Thanks to all for your help.

Offline sci_fi

  • Jr. Member
  • **
  • Posts: 86
Re: Alsamixer starts turned off.
« Reply #12 on: September 26, 2009, 06:15:25 AM »
alan, jls,

Thank you so much for your assistance. I have  alsa (really needed that sleep 4 as you suggested) and the skype version you provided working now. Initial skype testing seems OK. Possibly some voice quality issues on my transmission. I probably need to play with the alsa mic settings some more, but at least it works. Incoming voice quality is fine.

Thanks hugely, once again.

Now, I am free to go obsess about something else.

Best regards,

sci_fi

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: Alsamixer starts turned off.
« Reply #13 on: September 26, 2009, 06:20:38 AM »
I don't have any alsasound start in my bootlocal, but alsa works
« Last Edit: September 26, 2009, 07:45:31 AM by jls_legalize »
dCore user

Offline sci_fi

  • Jr. Member
  • **
  • Posts: 86
Re: Alsamixer starts turned off.
« Reply #14 on: September 26, 2009, 11:01:27 AM »
Yes, I have alsactl restore in bootlocal.sh. Not alsasound start. Works fine.