WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Alsamixer starts turned off.  (Read 7109 times)

Offline thane

  • Hero Member
  • *****
  • Posts: 691
Re: Alsamixer starts turned off.
« Reply #15 on: November 17, 2009, 01:27:25 AM »
<bump>

Ran into this same problem of alsa not starting up. In bootlocal.sh I rmmod and modprobe the sound chip to get the sample speed right and then run the alsasound start script. This generally works fine but when I ran TCL 2.5 with a very small set of extensions the sound didn't start. Adding sleep 4 to bootlocal.sh prior to the sound commands seems to resolve this. Some strange timing issue maybe? It started happening after I upgraded the extensions to the new squashfs [sp?] format where TCL boots faster than it used to.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: Alsamixer starts turned off.
« Reply #16 on: November 17, 2009, 03:12:23 AM »
I have seen the same behavior, were adding "/usr/locla/etc/init.d/alsasound start" did not work, but running the command just after booting to the desktop does work.  As you have stated, adding a sleep command in bootlocal.sh may be needed in some cases as it evidently is a timing issue.  I will add that to the info file as it is a common situation.

Offline thane

  • Hero Member
  • *****
  • Posts: 691
Re: Alsamixer starts turned off.
« Reply #17 on: November 17, 2009, 08:26:20 AM »
Dam, booted this morning and alsa didn't start even with sleep 4 in bootlocal.sh.

edit: rebooted and alsa started [???].

Further fiddling after I get home from work.

edit: sleep 6 seems to work, but I'll see.

edit: as of 11/21 sleep 6 works OK.
« Last Edit: November 21, 2009, 05:19:20 PM by thane »