WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: When running gparted in tc 14.0, some libs fail to be referenced.  (Read 843 times)

Offline PeterSuh

  • Newbie
  • *
  • Posts: 9
The installation of gparted went smoothly.
I used gparted in the same way in tc 12.0 and there were no problems.
Is this a bug in tc 14.0?

Code: [Select]
tc@box:~$ tce-load -iw gparted dosfstools mtools
tc@box:~$ sudo gparted
/usr/local/sbin/gpartedbin: symbol lookup error: /usr/local/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant

    [Edit]: Added code tags.  Rich
« Last Edit: February 27, 2024, 06:48:01 AM by Rich »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11282
Re: When running gparted in tc 14.0, some libs fail to be referenced.
« Reply #1 on: February 27, 2024, 06:47:12 AM »
Hi PeterSuh
Is  harfbuzz.tcz  installed?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14619
Re: When running gparted in tc 14.0, some libs fail to be referenced.
« Reply #2 on: February 27, 2024, 06:54:11 AM »
It might be good to check for updated extensions too.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11282
Re: When running gparted in tc 14.0, some libs fail to be referenced.
« Reply #3 on: February 27, 2024, 07:01:22 AM »
Hi PeterSuh
Also, is this for 32 or 64 bit TC14?

Offline PeterSuh

  • Newbie
  • *
  • Posts: 9
Re: When running gparted in tc 14.0, some libs fail to be referenced.
« Reply #4 on: February 27, 2024, 09:16:50 PM »
Hi PeterSuh
Is  harfbuzz.tcz  installed?

tc@box:~$ tce-load -iw harfbuzz
harfbuzz is already installed!

Offline PeterSuh

  • Newbie
  • *
  • Posts: 9
Re: When running gparted in tc 14.0, some libs fail to be referenced.
« Reply #5 on: February 27, 2024, 09:17:51 PM »
Hi PeterSuh
Also, is this for 32 or 64 bit TC14?

tc@box:~$ uname -a
Linux box 6.1.2-tinycore64 #612 SMP Mon Jan  2 17:24:30 UTC 2023 x86_64 GNU/Linux

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11282
Re: When running gparted in tc 14.0, some libs fail to be referenced.
« Reply #6 on: February 27, 2024, 09:55:18 PM »
Hi PeterSuh
tc@box:~$ uname -a
Linux box 6.1.2-tinycore64 #612 SMP Mon Jan  2 17:24:30 UTC 2023 x86_64 GNU/Linux
I have a machine running the same version and gparted works fine.

I recommend checking for updates as Juanito suggested.

To update extensions:
Code: [Select]
tce-audit builddb
tce-audit updatedeps
tce-audit fetchmissing
tce-update
exitcheck.sh reboot