WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: libatomic trouble after tce-update  (Read 2752 times)

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 934
libatomic trouble after tce-update
« on: December 16, 2023, 09:34:57 PM »
Greetings!

After tce-update of TC14 x86 many extensions were broken. At least wifi, mc, fonts and another ones. TC14 x86 becomes unusable. Many extensions ask for libatomic.so.1. I may have missed whether this is related to openssh update or pcre novations.

What can someone recommend to do in order to make TC14 x86 work?

Thanks in advance!

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11310
Re: libatomic trouble after tce-update
« Reply #1 on: December 16, 2023, 09:50:33 PM »
Hi jazzbiker
Does installing  gcc_libs.tcz  fix it?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11310
Re: libatomic trouble after tce-update
« Reply #2 on: December 16, 2023, 10:33:39 PM »
Hi jazzbiker
The new  openssl.tcz  now has a dependency on  gcc_libs.tcz.
The tree in TC13 looked like this:
Code: [Select]
mc.tcz
   glib2.tcz
      libffi.tcz
   libssh2.tcz
      openssl-1.1.1.tcz
   slang.tcz
      pcre.tcz
         bzip2-lib.tcz
   gpm.tcz
      ncursesw.tcz

In TC14 it now looks like this:
Code: [Select]
mc.tcz
   glib2.tcz
      libffi.tcz
      pcre21042.tcz
   libssh2.tcz
      openssl.tcz
         gcc_libs.tcz
   slang.tcz
      pcre.tcz
         bzip2-lib.tcz
   gpm.tcz
      ncursesw.tcz
   pcre.tcz
      bzip2-lib.tcz
libssh2.tcz  gained a dependency on  openssl.tcz , which should have
pulled in  gcc_libs.tcz.

These extensions have been recompiled against the new openssl"
https://forum.tinycorelinux.net/index.php/topic,26588.msg171487.html#msg171487

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 934
Re: libatomic trouble after tce-update
« Reply #3 on: December 17, 2023, 07:04:43 AM »
Hi RIch!

Using TC13 x86 I've added gcc_libs.tcz to my TC14 onboot.lst.
Booted TC14 x86, was able to connect to wifi network, executed update-everything. It showed that some dep files were updated. Then I've removed gcc_libs from onboot.lst and rebooted.
Still no libatomic, so no wifi, strange mc, another strangenesses, shut it down.

Guys, never use tce-update!

PS: looks like I'm the only user of TC14 x86 (

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: libatomic trouble after tce-update
« Reply #4 on: December 17, 2023, 07:37:10 AM »
gcc_libs provides libatomic, did you check the openssl dep file?
« Last Edit: December 17, 2023, 07:39:42 AM by Juanito »

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 934
Re: libatomic trouble after tce-update
« Reply #5 on: December 17, 2023, 09:28:47 AM »
Code: [Select]
tc@box:~$ ls /mnt/sdb3/tce14/optional/openssl.tcz.dep
ls: /mnt/sdb3/tce14/optional/openssl.tcz.dep: No such file or directory

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11310
Re: libatomic trouble after tce-update
« Reply #6 on: December 17, 2023, 09:37:17 AM »
Hi jazzbiker
Bingo, there's your problem.

This should fix it:
Code: [Select]
echo "gcc_libs.tcz" > /mnt/sdb3/tce14/optional/openssl.tcz.dep

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 934
Re: libatomic trouble after tce-update
« Reply #7 on: December 17, 2023, 09:53:43 AM »
Bingo, there's your problem.
Really? I thought it is problem of update-everything ...

@GNUser, we need You! Otherwise please rename update-everything into update-almost-everything :-)

Offline CardealRusso

  • Full Member
  • ***
  • Posts: 169
Re: libatomic trouble after tce-update
« Reply #8 on: December 17, 2023, 01:21:01 PM »
I've never had success updating tinycore using the update command, do I feel like I've had bad luck? If this is common with everyone, the script definitely needs to be reworked.

I currently keep an entire copy of the repository in /optional and use this rsync command to update, very fast and with zero worries.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11310
Re: libatomic trouble after tce-update
« Reply #9 on: December 17, 2023, 02:14:00 PM »
Hi jazzbiker
... Really? I thought it is problem of update-everything ...

@GNUser, we need You! Otherwise please rename update-everything into update-almost-everything :-)
Are you using an unsanctioned script for updates?  :o

Try it like this:
Code: [Select]
tce-audit builddb
tce-audit updatedeps
tce-audit fetchmissing
tce-update
exitcheck.sh reboot

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11310
Re: libatomic trouble after tce-update
« Reply #10 on: December 17, 2023, 02:21:23 PM »
Hi jazzbiker
Does this find an md5 file:
Code: [Select]
ls /mnt/sdb3/tce14/optional/openssl.tcz.md5.txt
If not, then this would explain the missing  .dep  file:
Hi GNUser
If an extension does not have a  .md5.txt  file included, do you still update the  .dep  file?
Hi Rich. No. update-everything does not touch foo.tcz.dep if local foo.tcz.md5.txt is missing:
Code: [Select]
elif [ ! -f $OPTIONALDIR/$extension.md5.txt ]; then
continue # if user deleted local md5.txt, it's likely a custom extension--leave it alone

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 934
Re: libatomic trouble after tce-update
« Reply #11 on: December 17, 2023, 03:24:04 PM »
Code: [Select]
tc@box:~$ ls /mnt/sdb3/tce14/optional/openssl.tcz.md5.txt
/mnt/sdb3/tce14/optional/openssl.tcz.md5.txt

Offline jazzbiker

  • Hero Member
  • *****
  • Posts: 934
Re: libatomic trouble after tce-update
« Reply #12 on: December 17, 2023, 07:48:03 PM »
Try it like this:
Code: [Select]
tce-audit builddb
tce-audit updatedeps
tce-audit fetchmissing
tce-update

Yes! This magic is able to resurrect even the .dep files gone!

Offline GNUser

  • Wiki Author
  • Hero Member
  • *****
  • Posts: 1378
Re: libatomic trouble after tce-update
« Reply #13 on: December 17, 2023, 09:52:10 PM »
Hi jazzbiker. Sorry for the hassle. You found a bug in how update-everything deals with .dep files.

Currently, update-everyhing makes sure that the .dep files on the system are identical to those in the repository. It does not currently check for missing .dep files or for extraneous .dep files (i.e., .dep files that exist on the local system but no longer exist in the repository). I will add this missing functionality.

Offline GNUser

  • Wiki Author
  • Hero Member
  • *****
  • Posts: 1378
Re: libatomic trouble after tce-update
« Reply #14 on: December 17, 2023, 11:27:06 PM »
Hi jazzbiker. I added the missing functionality:
* if .dep file is missing, it is added
* if .dep file is extraneous, it is removed

I tested it and it is working as intended:
https://gnuser.ddns.net/public/update-everything

I'll submit a pull request on github.

P.S. update-everything only looks at extensions with a .md5.txt extension. This is intentional so that:
* custom extensions (those without md5 file) are left in peace
* repo extensions with custom (changed/added/removed) .dep files can be left in peace if user deletes the extension's .md5.txt file
« Last Edit: December 17, 2023, 11:46:01 PM by GNUser »