WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: .xorg.conf file  (Read 12374 times)

Offline alexo

  • Jr. Member
  • **
  • Posts: 97
.xorg.conf file
« on: November 06, 2015, 05:05:18 AM »
Hi,
to enable some screen resolution not available in xvesa i would like to edit the .xorg.conf file, but
I don't find it; where is it?

second:

booting to xorg resets the keyboard map to american.
How can I restore to that I was using in xvesa?

thank you.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: .xorg.conf file
« Reply #1 on: November 06, 2015, 05:15:26 AM »
I'm not sure if a xorg.conf is always created but if present at  /etc/X11/xorg.conf  then it will be used.

You can also use snippets such as for keyboard layout:

/usr/local/share/X11/xorg.conf.d/10-keyboard.conf
Code: [Select]
Section "InputClass"
Identifier       "Keyboard Defaults"
MatchIsKeyboard  "yes"
        Option           "xkb_model" "pc105"
Option           "XkbLayout"   "de"
Option           "XkbOptions"  "terminate:ctrl_alt_bksp"
EndSection


Remember to add those files to your backup before rebooting.
Download a copy and keep it handy: Core book ;)

Offline alexo

  • Jr. Member
  • **
  • Posts: 97
Re: .xorg.conf file
« Reply #2 on: November 06, 2015, 11:00:07 AM »
Misalf, I have not /etc/X11 nor /usr/local/share/X11/xorg.conf.d
Am I missing any .tcz In my onboot services?
actually I replaced xvesa with xorg-7.7.tcz, nothing more
But when I reboot, the scrolling of a window or moving it around is very very slow.

In a post of some days ago nitram said:

Quote
Definitely a big performance difference between Xvesa and Xorg on slower hardware. Should you retry Xorg a custom xorg.conf file may help, specifying 16-bit color depth, in regards to scrolling and window manager performance. Modify the 'Screen' section in xorg.conf to something like:
Code: [Select]
[Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth    16
SubSection "Display"
Depth 16
Modes "1152x864"
EndSubSection
EndSection/code][/quote]

« Last Edit: November 06, 2015, 11:25:52 AM by alexo »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14535
Re: .xorg.conf file
« Reply #3 on: November 06, 2015, 07:52:22 PM »
If you loaded Xorg-7.7 in the usual way, it would have loaded xorg-server, which contains two files in /usr/local/share/X11/xorg.conf.d/

Since Xorg-7.7 will work without a configuration file in many cases, /etc/X11/xorg.conf is not present by default.
« Last Edit: November 06, 2015, 07:58:07 PM by Juanito »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: .xorg.conf file
« Reply #4 on: November 08, 2015, 03:19:49 AM »
Also make sure to add a valid driver. For example, if you have an Intel graphics card you would need  xf86-video-intel.tcz .
Download a copy and keep it handy: Core book ;)

Offline alexo

  • Jr. Member
  • **
  • Posts: 97
Re: .xorg.conf file
« Reply #5 on: November 08, 2015, 06:48:44 AM »
Thanks Misalf,
my laptop has an intel integrated video GPU.
I installed the xf86-video-intel.tcz driver for it and things work much much better; almost normally, I'd say. After reboot, it still remains the problem with the config file for the keyboard map that defaults to us.

After installing the driver, in usr/local/share there is an X11 folder with xorg.conf.d subdir.
It is not present in it the 10-keyboard.conf, tough, being there just 2 files:

10-evdev.conf
10-quirks.conf

So I created the file in /usr/local/share/X11/xorg.conf.d, added it to /opt/.filetool.lst and rebooted.
now I have the it keybord map working.

This is my 10-keyboard.conf file:

Code: [Select]
Section "InputClass"
Identifier       "Keyboard Defaults"
MatchIsKeyboard  "yes"
        Option           "xkb_model" "pc105"
Option           "XkbLayout"   "it"
Option           "XkbOptions"  "terminate:ctrl_alt_bksp"
EndSection

where I replaced de with it.

Thank you all.

Cheers,
alexo

Offline tcl-newbie

  • Newbie
  • *
  • Posts: 5
Re: .xorg.conf file
« Reply #6 on: November 10, 2015, 03:08:39 AM »
Hello,

sorry for posting my question in this post, but I have exactly the same problem.

I installed Xorg-7.7 and removed xvesa and now my keyboard layout is US. (But I boot in textmode and until I startx everything is fine!)

Using this solution and create /usr/local/share/X11/xorg.conf.d/10-keyboard.conf

Section "InputClass"
        Identifier       "Keyboard Defaults"
        MatchIsKeyboard  "yes"
        Option           "xkb_model" "pc105"
        Option           "XkbLayout"   "de"
        Option           "XkbOptions"  "terminate:ctrl_alt_bksp"
EndSection

I get "failed in WaitforX"

and checking /var/log/Xorg/Xorg.0.log it says

Parse error on line 2 of section InputClass in file /usr/local/share/X11/xorg.conf.d/10-keyboard.conf
"Identifier"  is not a valid keyword in this section.

Alternatively I created a /etc/X11/xorg.conf and /usr/local/share/X11/xorg.conf.d/10-keyboard.conf with the content

Section "InputDevice"
  Identifier "Keyboard"
  Driver "kbd"
  Option "XkbLayout" "de"
  Option "XkbVariant" "nodeadkeys"
  Option "Xkbmodel" "pc105"
EndSection

but this didn't help either. The layout was still US. It seemed as if Xorg is ignoring the config files.

Any idea would be very much appreciated!

Thanks in advance!


Offline tcl-newbie

  • Newbie
  • *
  • Posts: 5
Re: .xorg.conf file
« Reply #7 on: November 10, 2015, 03:46:35 AM »
Ok, it worked!

When copying it from the browser to the editor, the editor turned spaces into a cryptic sign, which I didn't see until I used the the editor of the file manager!

So, thanks for your help!

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: .xorg.conf file
« Reply #8 on: November 10, 2015, 03:23:02 PM »
Which editor did you use that did not work?
Download a copy and keep it handy: Core book ;)

Offline tcl-newbie

  • Newbie
  • *
  • Posts: 5
Re: .xorg.conf file
« Reply #9 on: November 10, 2015, 05:15:23 PM »
Hello,

I simply copied from the browser (Dillo) to the editor (the basiceditor installed with the core+ installation)  and saved it.
It looks fine, but opening it with vi the substitution of the spaces becomes visible.

I don't know if the editor is causing this or the browser, but I experienced this before when copying text from a browser in a editor or in some kind of word processor.
« Last Edit: November 10, 2015, 05:18:56 PM by tcl-newbie »

Offline alexo

  • Jr. Member
  • **
  • Posts: 97
Re: .xorg.conf file
« Reply #10 on: November 22, 2015, 02:00:58 AM »
Hi Nitram,


In a post of some days ago nitram said:

Quote
Definitely a big performance difference between Xvesa and Xorg on slower hardware. Should you retry Xorg a custom xorg.conf file may help, specifying 16-bit color depth, in regards to scrolling and window manager performance. Modify the 'Screen' section in xorg.conf to something like:
Code: [Select]
[Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth    16
SubSection "Display"
Depth 16
Modes "1152x864"
EndSubSection
EndSection/code][/quote]

I would like to reduce the screen resolution in xorg. I changed the keyboard layout by creating a 10-keyboard.conf file in /usr/local/share/X11/xorg.conf.d, but I don't know how to edit screen resolution. I don't see any screen related file in there.
You gave me that snippet of code but I didn't understand what to do with it and how to name that file.
My monitor says I'm running 1400x1050 resolution but for my intel video card I think it's too much: color gradient background is not fluid but with narrow stripes of color. Could you explain me how to do it?
Thank you

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: .xorg.conf file
« Reply #11 on: November 22, 2015, 02:39:52 AM »
Any file in  /usr/local/share/X11/xorg.conf.d  with the file name extension  .conf  will be processed by Xorg.
I think you can create a  .conf  file for your display by copy/pasting the  Screen  entry from your current  /etc/X11/xorg.conf  and changing the  Modes  option.
Download a copy and keep it handy: Core book ;)

Offline alexo

  • Jr. Member
  • **
  • Posts: 97
Re: .xorg.conf file
« Reply #12 on: November 22, 2015, 02:53:53 AM »
There is no /etc/X11 folder.
I searched for "xorg" in / and subfolders and there's neither the xorg.conf file



Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: .xorg.conf file
« Reply #13 on: November 22, 2015, 03:06:41 AM »
Hmm... Well, then try creating this file

/usr/local/share/X11/xorg.conf.d/YOUR-SCREEN.conf
Code: [Select]
Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth    16
SubSection "Display"
Depth 16
Modes "1152x864"
EndSubSection
EndSection


Change  Modes "1152x864"  to your screen resolution.
Download a copy and keep it handy: Core book ;)

Offline alexo

  • Jr. Member
  • **
  • Posts: 97
Re: .xorg.conf file
« Reply #14 on: November 22, 2015, 05:56:18 AM »
It worked!
Thank you Misalf,

I'd like to know if  there is a way to know the resolution actually running before change it via .conf file.
This because having TC on a USB stick, it gets loaded from two different systems with different monitors and resolution.

Thanks alot for your patience and advises