WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: firefox-getLatest.tcz no longer works and has a few issues  (Read 6891 times)

Offline zatman

  • Newbie
  • *
  • Posts: 18
firefox-getLatest.tcz no longer works and has a few issues
« on: October 23, 2015, 07:46:49 PM »
Hello,

I have known about one issue (with firefox-getLatest.tcz and firefox-latest.tcz) for sometime, but was able to get around it, with a simple deleting of a file.  But now there is a new problem, which I am unable to resolve.  I will list all issues below.

1) With the recent server hard drive (http://forum.tinycorelinux.net/index.php/topic,19021.msg116842.html#new) problem (repo.tinycorelinux.net), it created a problem for this tcz app, based on the code needing this server to work.  Please see attached file (01.png), it shows an ip address of 89.22.99.37, which is "repo.tinycorelinux.net".  The (firefox-getLatest.sh) code which refers to this is below.

Code: [Select]
echo -e "\n ${BLUE}Fetching dependencies${NORMAL}.. "
unset address
unset message
address="http://tinycorelinux.net/index.html"
message=$message1
f_connchk

Even if the user changes to a different mirror, the app is hard coded to use (http://tinycorelinux.net/index.html) this server, to check the dependencies.  With the server offline (or was, till recently), the program will not continue.

Not sure if this will help, but would changing the address line to this (see below), work?

Code: [Select]
address="$MIRROR"
So when the user changes to a new mirror, the address (line above) will use the same repo server, the user selected.


2) When the (firefox-getLatest) app tries to download the firefox tar (bz2) file, it's trying to download it as FTP only vs HTTP, which was discussed in a prior forum entry (http://forum.tinycorelinux.net/index.php/topic,17879.msg116344.html#msg116344).  There was to be new code added (per coreplayer2), which should fix the issue.

Code: [Select]
latestVER="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-i686/en-US"
I do not think this new code has been updated in the current release.  When will it be added?


2B)

Also related, is the URL (listed above), which no longer seems to work.  Mozilla must have changed it recently?  I have included the new one below.

Code: [Select]
http://ftp.mozilla.org/pub/firefox/releases/latest/linux-i686/en-US/

3)  When the app was working, or sort of, it did have a minor issue of crashing, if I already had fontconfig.tcz file downloaded and installed.   I use tightvnc, which has a number of dep. files, and one is libXft.tcz ---> dep ---> fontconfig.tcz.  The (firefox-getLatest) app does not give any error, it just closes the terminal window, when trying to download fontconfig.tcz.  This is easily repeatable.  My quick fix was to delete all fontconfig files (in tmp/tce/optional), then restart the app.

Thanks for any help.

Not sure if it matters - using TC 6.x

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11305
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #1 on: October 23, 2015, 08:08:00 PM »
Hi zatman
Maybe you should address these issues here:
http://forum.tinycorelinux.net/index.php/topic,17879.msg116842.html#msg116842

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #2 on: October 23, 2015, 11:18:13 PM »
I have known about one issue (with firefox-getLatest.tcz and firefox-latest.tcz) for sometime, but was able to get around it, with a simple deleting of a file.
Would have been nice to know earlier, but please elaborate

Quote
1)  ...Even if the user changes to a different mirror, the app is hard coded to use (http://tinycorelinux.net/index.html) this server, to check the dependencies.
This has been addressed and fixed already.  Actually is not related to mirror or dependencies, but is simply used to verify an internet connection, the issue came to light when the server hard drive died this week.

Quote
2) When the (firefox-getLatest) app tries to download the firefox tar (bz2) file

2B) Also related, is the URL (listed above), which no longer seems to work.  Mozilla must have changed it recently?  I have included the new one below.
http://ftp.mozilla.org/pub/firefox/releases/latest/linux-i686/en-US/
Already fixed in previous update.    Additionally is not related to the firefox*.tar file, instead is attempting to download an en-US txt file in determining the latest available version.  But with Mozilla's recent web site change it no longer exists, so an md5sum file at same location is used instead, until the great folks at Mozilla change it again..

These two basic issues have been addressed and the latest extension update has been submitted today, maybe it will be in repo on Sunday???  or by next weekend, It's out of my hands..

Quote
3)  When the app was working... it did have a minor issue of crashing, if I already had fontconfig.tcz file downloaded and installed.   I use tightvnc, which has a number of dep. files, and one is libXft.tcz ---> dep ---> fontconfig.tcz.  The (firefox-getLatest) app does not give any error, it just closes the terminal window, when trying to download fontconfig.tcz.  This is easily repeatable.  My quick fix was to delete all fontconfig files (in tmp/tce/optional), then restart the app.
This is not related to firefox-getLatest extension per se, but is caused because needed md5.txt files and most likely fontconfig.tcz.md5.txt file were missing from your optional directory.   Using the preferred APPS gui or tce-ab from the command line to install extensions with appropriate md5 files should resolve your issue.   If this happens with other extensions it's best to remove all related extensions including their dep files and md5 files then start over.

Thanks for reporting


Please see here for more info and the updated script from firefox-getLatest extension
http://forum.tinycorelinux.net/index.php/topic,17879.msg116842.html#msg116842
« Last Edit: October 23, 2015, 11:32:36 PM by coreplayer2 »

Offline zatman

  • Newbie
  • *
  • Posts: 18
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #3 on: October 24, 2015, 01:14:09 PM »
Quote
Would have been nice to know earlier, but please elaborate

Quote
caused because needed md5.txt files and most likely fontconfig.tcz.md5.txt file were missing from your optional directory

Sorry for not letting you know earlier, but I treat the tinycore team as a valuable resource, and only to be used sparingly.  I think you are correct, regarding my optional directory does not have the md5 file for fontconfig, and will recheck, when I try installing firefox again.  My install of tightvnc, is via the onboot.lst process, which I have only put the bare minimum of files in the list, and its using a local http file server, to pull the files from, which does not include the md5 files.

Thanks again coreplayer2, for all your info and program updates.

Offline chattrhand

  • Full Member
  • ***
  • Posts: 140
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #4 on: November 04, 2015, 08:53:28 AM »
hi TinyCoreTeam,

a workaround for the existing firefox-latest utility on tc-6.4 for dumb users like me:
Start firefox-latest from deskop menu, and when it stops with
"Error acquiring latest version"
enter 42.0 and tc replaced the previous firefox version as it should.
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #5 on: November 04, 2015, 09:56:02 PM »
Unfortunately Mozilla removed all md5sum files within their server directory structure which caused this issue today

You can also run the script in the terminal to enter the desired version
Code: [Select]
firefox-getLatest.sh -m
or you can download the updated (fixed) script which addresses this specific problem form here
http://forum.tinycorelinux.net/index.php/topic,17879.msg117431.html#msg117431

the updated extension will be submitted asap

thanks

Offline thane

  • Hero Member
  • *****
  • Posts: 691
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #6 on: November 05, 2015, 10:54:44 PM »
The updated script worked. Had to get around a couple of permissions issues -- used sudo fluff to copy the script from my download folder to usr/local/bin (couldn't put it there directly from Firefox), and then used chmod 777 firefox-getLatest.sh to allow me to execute it. Somebody who knows more about Linux may have a simpler solution though!

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #7 on: November 05, 2015, 11:13:46 PM »
Am glad the update worked for you.  I've submitted the updated extension today so it should be available in the repo soon


Sent from my iPhone using Tapatalk

Offline chattrhand

  • Full Member
  • ***
  • Posts: 140
firefox-latest not working correctly
« Reply #8 on: November 06, 2015, 10:29:20 AM »
Hello TinyCoreTeam,

sorry, i've just updated core.gz and vmlinuz of my stick to tc-6.4.1 and all extensions that are to be updated via apps-browser (except firefox).too.

Then I started firefox-latest, but again the first option to select the last version was missing again.

So I manually added 42.0 and the upgrade worked fine. (42 or 42. are treated as typos, that's ok)

btw: since tce 6.0 the german umlauts äöüßÄÖÜ are written correctly by the tc-editor, while in the terminal they write only '?' question marks.

chattrhand
TinyCore, SliTaz, LinuxMint, Tails, Mac ...

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
firefox-getLatest.tcz no longer works and has a few issues
« Reply #9 on: November 06, 2015, 05:42:18 PM »
Hello Chattrhand, please give the update process a chance.  The updated extension Firefox-getLatest has just been submitted and may take a week to be in repo

Pm me if you need the latest fixed version

Yes to use the manual option you must be specific. Like 42.0 as 42 or 42. are in error


Sent from my iPhone using Tapatalk
« Last Edit: November 06, 2015, 05:44:32 PM by coreplayer2 »

Offline hiro

  • Hero Member
  • *****
  • Posts: 1228
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #10 on: January 01, 2016, 09:07:33 PM »
hello coreplayer2. firefox-getlatest works on tc6, but not on tc4.
one issue is the squashfs dependency being different on tc4 and second issue is probably that the extensions just hasn't been updated in tc4, thus it complains about 404 errors.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #11 on: January 01, 2016, 09:44:52 PM »
Hello Hiro

Please use firefox_getLatest.tcz  which is the latest and works with tc5/6/7 


Offline hiro

  • Hero Member
  • *****
  • Posts: 1228
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #12 on: January 01, 2016, 11:01:50 PM »
yes, I agree that it works on tc6, but what's up with tc4? :)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #13 on: January 02, 2016, 12:12:56 AM »
Hi hiro

I keep a copy of tc5 for backwards compatibility testing, as soon as tc7 has a final release i'll keep only tc6 for the same reason.     You can see where I'm going with this right??   I could be wrong, but to my knowledge firefox_getLatest.tcz has never been uploaded to or tested with the tc4 repo extensions.

Though I do understand what you're saying.  It appears I made an assumption, that folks would already have squashfs-tools installed, but that's the real problem right??  Not sure what i was thinking there..   I'll correct that issue in a future extension asap


Ok a quick fix for you is simply create a dep file with the correct squashfs-tools-4.x.tcz listed.




Quote
yes, I agree that it works on tc6...
Which extension firefox_getLatest.tcz  or firefox-getLatest.tcz  ?


Please note that firefox-getLatest.tcz  has been deprecated in favor of firefox_getLatest.tcz
see here for more http://forum.tinycorelinux.net/index.php/topic,17879.msg118894.html#msg118894


« Last Edit: January 02, 2016, 12:25:34 AM by coreplayer2 »

Offline hiro

  • Hero Member
  • *****
  • Posts: 1228
Re: firefox-getLatest.tcz no longer works and has a few issues
« Reply #14 on: January 02, 2016, 07:38:08 AM »
You're right, on tc4 i've been using firefox-getLatest.tcz. Only now I realize what you mean, before I plainly didn't *see* the difference in the name.

I did see some fairly recent entries in the changelog so I thought it is maintained even for tc4.