WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)  (Read 8325 times)

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« on: April 19, 2015, 01:41:29 PM »
I've tried to bring in work the lirc which was kindly added into the repo, but no working results.
At the Rasbian is still used older 0.9.0 which works fine. But in the repo is used the most newest version 0.9.2a which seems to have different data format in the config file. Comparison for the same remote and same buttons.

Older:
Code: (bash) [Select]
begin remote
 
  name  /home/pi/lircd.conf
  bits           16
  flags SPACE_ENC|CONST_LENGTH
  eps            30
  aeps          100
 
  header       8945  4421
  one           594  1634
  zero          594   519
  ptrail        598
  repeat       8949  2187
  pre_data_bits   16
  pre_data       0xFD
  gap          106959
  toggle_bit_mask 0x0
 
      begin codes
          KEY_KPMINUS           0x00FF
          KEY_KPPLUS             0x40BF
      end codes
 
end remote

The new one:
Code: (bash) [Select]
begin remote

  name  /home/tc/lircd.conf
  driver devinput
  bits           64
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  gap          409
  toggle_bit_mask 0x0

      begin codes
          KEY_KPMINUS              0x1118000001000259 0x00000000BEA9C9B1
          KEY_KPPLUS               0x112800000100024D 0x00000000BEA9C9B1
      end codes

end remote

I've used the same steps as for the older one, recorded the remote keys, put to the /usr/local/etc/lirc directory where the config  files are stored and started the lircd daemon as root, which indicates that config was loaded and everything is working, but it's not true. I've tested
Code: (bash) [Select]
sudo irw /var/run/lirc/lircd

which indicates that the socket was connected, but no data coming when button-press.

Has anybody experience with this new lirc version and how to bring it working?

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #1 on: April 20, 2015, 03:34:20 AM »
I've made it somehow partially working with the config file generated in the 0.9.0 irrecord. But it outputs only to the /var/run/lirc/lircd. The irw shows good results.
 Even when I use the -u parameter to output to the uinput, the uinput module is loaded and used, the output is no more to the /var/run/lirc/lircd, but the virtual input device is not created and no output.

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #2 on: April 20, 2015, 04:37:12 AM »
Next step, when used
Code: (bash) [Select]
sudo lircd -u
uinput created the device /sys/devices/virtual/input2, but there is no output.
 Even more, there is no any other lirc output anywhere. Any idea what's wrong with the lircd setup?

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7183
    • My Community Forum
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #3 on: April 20, 2015, 04:41:27 AM »
Unfortunately I can't help, just built the extension from the source. You may build the older version you know and when it is up and running try to update.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #4 on: April 20, 2015, 05:34:29 AM »
Hi Béla,

thank's for the info, but hence I'm not skilled in the building, it's hard to me to test the older version.

Regards,

Jan

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #5 on: April 20, 2015, 07:25:59 AM »
Béla,
I've tried to compile the older version, I've the source files, installed dialog and cmake, but still there is error that there is no acceptable C compiler. Please be so kind and provide the .setup.config and which compiler you're using.

Regards,

Jan

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #6 on: April 20, 2015, 07:53:37 AM »
Even gcc compiler seems not to work well. Please see the attached log and setup.
Please be so kind and help what I'm doing wrong.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11321
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #7 on: April 20, 2015, 10:14:56 AM »
Hi jgrulich
Did you install  compile-essentials.tcz

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #8 on: April 20, 2015, 11:12:54 AM »
Hi Rich,

yes, hoped that I have everything, but probably still something wrong, now I have the error /lib/cpp sanity check.
Seems that some specific kernel libraries are still missing. Or may be that for Raspi need to be used some modified source code than is the one from here: http://sourceforge.net/projects/lirc/files/LIRC/0.9.0/, or need to be used some patch.

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #9 on: April 20, 2015, 11:35:27 AM »
Attached is the log for detailed info.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11321
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #10 on: April 20, 2015, 12:50:06 PM »
Hi jgrulich
Quote
/usr/include/bits/local_lim.h:38:26: fatal error: linux/limits.h: No such file or directory
That sounds like you might be missing the  linux api headers

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #11 on: April 20, 2015, 01:05:54 PM »
Yes, it hit me too, but was wondering for what the api may be useful for this build. But will try to install them and test.

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #12 on: April 20, 2015, 02:18:56 PM »
I've got it compiling well, but hit the issue with the input device driver. I've found that there is missing the lirc_rpi GPIO as a input driver.

Offline lykkedk

  • Full Member
  • ***
  • Posts: 182
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #13 on: April 20, 2015, 04:02:51 PM »
Hi there...

Lirc_rpi is a kernel module, which you do not compile when building lirc.
I think its inside a .tcz with rc-kernelversion or soo... Try a tce search for rc.

Rc is kernelmodules for remotecontrol .. Tadaa  :o

Try to look at post 1929 to around 1933, i (jesperlykke) posted a long time ago regarding lirc.

You can also find some post here in this forum, by looking for lykkedk.

http://forums.slimdevices.com/showthread.php?97803-piCoPlayer-Squeezelite-on-Microcore-linux-An-embedded-OS-in-RAM-with-Squeezelite/page193

Good luck; Jesper.

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: lirc-0.9.2a(devinput) or lirc-0.9.0-pre1(default)
« Reply #14 on: April 20, 2015, 05:16:03 PM »
Hi Jesper,

I know whats' lirc_rpi, lirc_dev and so on. It's a part of rc-kernel modules.
For older lirc version - 0.9.0 there is config table when started ./configure. But there is missing the driver for GPIO device, or "default" like for 0.9.2 version. There is completely different structure and no configuration available at the startup of compilation.
As I've stated at the beginning of this thread, the issue is that the 0.9.2 version is not working into the uinput virtual device.
I've tested to build the package exactly matching to my distro, but the same result.

Regards,

Jan