WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Wireless 2.6.26 not "reloading" at boot  (Read 6339 times)

Offline JB-Linux

  • Newbie
  • *
  • Posts: 1
Wireless 2.6.26 not "reloading" at boot
« on: December 06, 2008, 10:23:53 AM »
First off, Hello.  Looks like there is a great project going on here.  Here is what I have got....

Tiny Core Linux RC3

A "frugal" install on the hard drive booting with grub:

root (hd0,4)
kernel /bzImage quiet laptop tclocal=hda5

I am also using the tclocal "file" format (I have also tried the directory format).  Other extensions seem to work fine, ie. emelfm, leafpad, minefield, but Wireless 2.6.26.tcem is not loading.  I have also tried Xorg and got errors.  One thing I observed is that is seems the *.tcem (module extensions? correct me if I am wrong), do not seem to "stick" after shutting down.

BTW - I was able to get wireless working with this extension :) - It was lost after a reboot though :(

Thanks in advance,

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10994
Re: Wireless 2.6.26 not "reloading" at boot
« Reply #1 on: December 06, 2008, 01:53:36 PM »
Not all extensions are fully in /usr/local yet - mostly those with modules ie .tcem.
Work is underway to bring those too there.

Xorg is 99% in /usr/local, the only pieces outside are /var/lib/xkb (directory) for compiled keymaps, and the user-provided config file /etc/X11/xorg.conf.
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: Wireless 2.6.26 not "reloading" at boot
« Reply #2 on: December 15, 2008, 01:16:25 PM »
As of Tinycore 1.0rc6 the framework for supporting kernel modules in /usr/local is complete.  So kernel modules can be supported in PPI mode without being reloaded upon each boot.  Alsa modules do not like this kind of thing just like they don't like tcz format for reasons not yet known.  But so far all other modules I have tried get recognized by depmod when installed into /usr/local.  Even OSS works with it's modules in /usr/local, but the extension would have to get recompiled to by fully under tclocal.  I rebuilt my own copy of wireless-2.6.26.tcem with the modules installed in /usr/local and tested it.  I don't have wireless to test their function with, but modules.dep is rebuilt correctly  when the extension is loaded and the modules get loaded along with their dependencies by modprobe. 
What has been done is a symlink has been added:
/lib/modules/2.6.26-tinycore/kernel.tclocal  ->  /usr/local/lib/modules/2.6.26-tinycore/kernel

Therefore to make an extension that installs the modules into /usr/local, just add /usr/local to the front of the /lib directory where the modules get normally installed.  Kind of like this:

cd /tmp
mkdir -p pkg pkg1/usr/local
tar xzvf wireless-2.6.26.tcem -C pkg
mv pkg/lib pkg1/usr/local
cd pkg1
find . -not -type d > /tmp/list
tar -T /tmp/list -czvf /home/tc/wireless-2.6.26.tcem

This should help support PPI and reduce the need to load kernel module extensions on each boot once they are installed, as well as reduce memory usage.
« Last Edit: December 15, 2008, 01:19:23 PM by Jason W »

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
Re: Wireless 2.6.26 not "reloading" at boot
« Reply #3 on: December 15, 2008, 10:12:20 PM »
I have also tried Xorg and got errors. 
Is it intel card?