WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.  (Read 14625 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #15 on: January 12, 2012, 01:45:42 AM »
Do you have Xorg-7.6 running and set up with the appropriate 3d driver for your hardware?

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #16 on: January 12, 2012, 02:09:47 AM »
Do you have Xorg-7.6 running and set up with the appropriate 3d driver for your hardware?
installed: Xorg-7.5 Xorg-7.5-3d ati-fglrx.
Xorg and ati-fglrx are working.
« Last Edit: January 12, 2012, 02:15:37 AM by aswjh »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #17 on: January 12, 2012, 02:18:56 AM »
OK, so I'm out of ideas  :(

do you have the url for the google earth and lsb-core rpms?
« Last Edit: January 12, 2012, 02:20:31 AM by Juanito »

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
« Last Edit: January 12, 2012, 04:49:58 AM by aswjh »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #19 on: January 12, 2012, 04:20:59 AM »
I unpacked the google rpm, but not the lsb rpms

Here's what I got:
Code: [Select]
$ cd /lib
$ sudo ln -s ld-linux.so.2 ld-lsb.so.3

$ /tmp/pkg/opt/google/earth/free/googleearth
./googleearth-bin: symbol lookup error: ./libQtWebKit.so.4: undefined symbol: _Z34QBasicAtomicInt_fetchAndAddOrderedPVii

Using googleearth (as opposed to googleearth-bin) will load the google libs - at the time I had the qt-4.x-base extension loaded, but not the qt-4.x-webkit extension, so this error is possibly due to the google libQtWebKit lib trying to call something missing from the tinycore libQt libs

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #20 on: January 12, 2012, 04:57:43 AM »
I unpacked the google rpm, but not the lsb rpms

Here's what I got:
Code: [Select]
$ cd /lib
$ sudo ln -s ld-linux.so.2 ld-lsb.so.3

$ /tmp/pkg/opt/google/earth/free/googleearth
./googleearth-bin: symbol lookup error: ./libQtWebKit.so.4: undefined symbol: _Z34QBasicAtomicInt_fetchAndAddOrderedPVii

Using googleearth (as opposed to googleearth-bin) will load the google libs - at the time I had the qt-4.x-base extension loaded, but not the qt-4.x-webkit extension, so this error is possibly due to the google libQtWebKit lib trying to call something missing from the tinycore libQt libs
Yes,googleearth is running now,thank you very much.
$sudo rpm -i /mnt/sda7/tinycore/packages/google-earth-stable_current_i386.rpm;
$tce-load -i qt-4.x-base qt-4.x-webkit qt-4.x-opengl
$for i in `ldd /opt/google/earth/free/googleearth-bin|grep "not found"|cut -d' ' -f1`;do sudo ln -fs /opt/google/earth/free/$i /lib/;done;
$for i in `ldd /opt/google/earth/free/googleearth-bin|grep "not found"|cut -d' ' -f1`;do sudo ln -fs /opt/google/earth/free/$i /lib/;done;
$ cd /lib
$ sudo ln -s ld-linux.so.2 ld-lsb.so.3
$ google-earth
Now googleearth is working well.
Thank you.

« Last Edit: January 12, 2012, 04:28:25 PM by aswjh »