WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.  (Read 14626 times)

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
tiny core 4.2.1:
$sudo rpm -i ./google-earth-stable_current_i386.rpm
$google-earth
/usr/bin/google-earth: line 43: ./googleearth-bin: not found

$/opt/google/earth/free/googleearth-bin
sh: /opt/google/earth/free/googleearth-bin: not found

$ ls -la /opt/google/earth/free/goo*
-rwxr-xr-x 1 root root 1112 2011-09-15 10:53 /opt/google/earth/free/googleearth
lrwxrwxrwx 1 root root   34 2012-01-12 09:54 /opt/google/earth/free/google-earth -> /opt/google/earth/free/googleearth
-rwxr-xr-x 1 root root 5368 2011-10-17 11:10 /opt/google/earth/free/googleearth-bin
-rw-r--r-- 1 root root  390 2011-10-17 11:10 /opt/google/earth/free/google-earth.desktop

and installed  LSB 4.1 SDK (x86)  (extract lsb-sdk-4.1.2-1.ia32.tar.gz  to /tmp ):
$ for i in `ls /tmp/lsb-sdk/*.rpm`;do sudo rpm -i $i;done

What can i do?
thanks.

« Last Edit: January 11, 2012, 07:09:18 PM by aswjh »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11261
Hi aswjh
Maybe you need to add it to your path?
PATH=$PATH:/opt/google/earth/free

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Hi aswjh
Maybe you need to add it to your path?
PATH=$PATH:/opt/google/earth/free
the same.
thank you.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11261
Hi aswjh
What if you change into the directory first?
cd /opt/google/earth/free

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Hi aswjh
What if you change into the directory first?
cd /opt/google/earth/free

Error still.Perhaps lsb-core is incorrect,but i don't know what should i do.
« Last Edit: January 11, 2012, 07:30:42 PM by aswjh »

Offline maro

  • Hero Member
  • *****
  • Posts: 1228
My hunch would be that 'googleearth-bin' is a script (which is likely given it's small size of 5368 bytes) that contains a shebang entry (e.g. '#!/bin/bash') that your TC system can't cope with.

To figure this out I'd suggest you run head -1 /opt/google/earth/free/googleearth-bin If my assumption is correct you will just have to install the respective extension (e.g. via tce-load -wi bash) to overcome this hurdle.

I've found that these kind of scripts very often don't really need the 'bash'. My "quick and dirty" test would be whether the default shell can syntactically cope with the script (e.g. via /bin/sh -n /opt/google/earth/free/googleearth-bin). If that appears to be the case, you could then just try a different shebang entry (i.e. '/bin/sh' instead of '/bin/bash'). Provided everything is working you could then save yourself the installation of the 'bash.tcz' extension.

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
My hunch would be that 'googleearth-bin' is a script (which is likely given it's small size of 5368 bytes) that contains a shebang entry (e.g. '#!/bin/bash') that your TC system can't cope with.

To figure this out I'd suggest you run head -1 /opt/google/earth/free/googleearth-bin If my assumption is correct you will just have to install the respective extension (e.g. via tce-load -wi bash) to overcome this hurdle.

I've found that these kind of scripts very often don't really need the 'bash'. My "quick and dirty" test would be whether the default shell can syntactically cope with the script (e.g. via /bin/sh -n /opt/google/earth/free/googleearth-bin). If that appears to be the case, you could then just try a different shebang entry (i.e. '/bin/sh' instead of '/bin/bash'). Provided everything is working you could then save yourself the installation of the 'bash.tcz' extension.
Thank you.

$ head -1 /opt/google/earth/free/googleearth-bin
ELF44(444444ttt牗垐坔hHHHDDQ錿dR錿dttt寣/lib/ld-lsb.so.3GNUGNU2ヂ航a$3媺M坕峭$
$ file /opt/google/earth/free/googleearth-bin
/opt/google/earth/free/googleearth-bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, BuildID[sha1]=0x01c2a53261bdba12898b3324c769884dbb2419cd, stripped

It seems that googleearth-bin isn't a script file.




Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
What about:
Code: [Select]
$ ldd /opt/google/earth/free/googleearth-bin
or

Code: [Select]
$ /opt/google/earth/free/googleearth-bin --help..to see if you can try to start it in dubug/verbose mode

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
What about:
Code: [Select]
$ ldd /opt/google/earth/free/googleearth-bin
or

Code: [Select]
$ /opt/google/earth/free/googleearth-bin --help..to see if you can try to start it in dubug/verbose mode

$ ldd /opt/google/earth/free/googleearth-bin
        linux-gate.so.1 =>  (0xb7891000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7871000)
        libdl.so.2 => /lib/libdl.so.2 (0xb786d000)
        libgoogleearth_free.so => not found
        libQtCore.so.4 => not found
        libQtGui.so.4 => not found
        libQtNetwork.so.4 => not found
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0xb783e000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb77da000)
        libcurl.so.4 => /usr/local/lib/libcurl.so.4 (0xb75cb000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb74ca000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb74c1000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb74af000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb73c4000)
        libGLU.so.1 => /usr/local/lib/libGLU.so.1 (0xb7368000)
        librt.so.1 => /lib/librt.so.1 (0xb7360000)
        libQtWebKit.so.4 => not found
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb729d000)
        libm.so.6 => /lib/libm.so.6 (0xb727a000)
        libc.so.6 => /lib/libc.so.6 (0xb716f000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb7159000)
        /lib/ld-lsb.so.3 => /lib/ld-linux.so.2 (0xb7892000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb7147000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0xb7127000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb7124000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb711e000)

$ /opt/google/earth/free/googleearth-bin --help
sh: /opt/google/earth/free/googleearth-bin: not found


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
So there's your problem:
Code: [Select]
        libgoogleearth_free.so => not found
        libQtCore.so.4 => not found
        libQtGui.so.4 => not found
        libQtNetwork.so.4 => not found
        libQtWebKit.so.4 => not found

You can use the "provides" function in the apps browser to download and load the appropriate missing extensions (except libgoogleearth I presume).

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #10 on: January 11, 2012, 11:50:35 PM »
So there's your problem:
Code: [Select]
        libgoogleearth_free.so => not found
        libQtCore.so.4 => not found
        libQtGui.so.4 => not found
        libQtNetwork.so.4 => not found
        libQtWebKit.so.4 => not found

You can use the "provides" function in the apps browser to download and load the appropriate missing extensions (except libgoogleearth I presume).

Done.

$ for i in `find /opt/google/earth/free|grep -i .so`;do sudo ln -s $i /lib/;done;
$ ldd /opt/google/earth/free/googleearth-bin
        linux-gate.so.1 =>  (0xb779a000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb777a000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7776000)
        libgoogleearth_free.so => /lib/libgoogleearth_free.so (0xb7683000)
        libQtCore.so.4 => /lib/libQtCore.so.4 (0xb7389000)
        libQtGui.so.4 => /lib/libQtGui.so.4 (0xb691d000)
        libQtNetwork.so.4 => /lib/libQtNetwork.so.4 (0xb67f1000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0xb67c3000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb675f000)
        libcurl.so.4 => /lib/libcurl.so.4 (0xb672c000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb662b000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6622000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb6610000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb6525000)
        libGLU.so.1 => /lib/libGLU.so.1 (0xb64a7000)
        librt.so.1 => /lib/librt.so.1 (0xb649f000)
        libQtWebKit.so.4 => /lib/libQtWebKit.so.4 (0xb549c000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb53da000)
        libm.so.6 => /lib/libm.so.6 (0xb53b7000)
        libc.so.6 => /lib/libc.so.6 (0xb52ac000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb5296000)
        /lib/ld-lsb.so.3 => /lib/ld-linux.so.2 (0xb779b000)
        libIGCore.so => /lib/libIGCore.so (0xb51a6000)
        libIGUtils.so => /lib/libIGUtils.so (0xb517d000)
        libapiloader.so => /lib/libapiloader.so (0xb5179000)
        libauth.so => /lib/libauth.so (0xb510a000)
        libbase.so => /lib/libbase.so (0xb501d000)
        libcommon.so => /lib/libcommon.so (0xb4f82000)
        libcommon_gui.so => /lib/libcommon_gui.so (0xb4f5f000)
        libcommon_platform.so => /lib/libcommon_platform.so (0xb4f59000)
        libcommon_webbrowser.so => /lib/libcommon_webbrowser.so (0xb4f11000)
        libcomponentframework.so => /lib/libcomponentframework.so (0xb4f0a000)
        libgeobase.so => /lib/libgeobase.so (0xb4c15000)
        libgeobaseutils.so => /lib/libgeobaseutils.so (0xb4bc8000)
        libge_net.so => /lib/libge_net.so (0xb4b7b000)
        libgoogleapi.so => /lib/libgoogleapi.so (0xb4b5f000)
        libmath.so => /lib/libmath.so (0xb4b18000)
        libmoduleframework.so => /lib/libmoduleframework.so (0xb4b0a000)
        libport.so => /lib/libport.so (0xb4b01000)
        libprofile.so => /lib/libprofile.so (0xb4afe000)
        librender.so => /lib/librender.so (0xb4aa9000)
        libreporting.so => /lib/libreporting.so (0xb4a9c000)
        libsgutil.so => /lib/libsgutil.so (0xb497f000)
        libspatial.so => /lib/libspatial.so (0xb4792000)
        libxsltransform.so => /lib/libxsltransform.so (0xb478d000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb477b000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb4773000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb475a000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0xb473a000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb4737000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb4730000)
        libIGMath.so => /lib/libIGMath.so (0xb46e8000)
        libgdata.so => /lib/libgdata.so (0xb46d1000)
        libfusioncommon.so => /lib/libfusioncommon.so (0xb46cb000)
        libIGAttrs.so => /lib/libIGAttrs.so (0xb464a000)
        libIGGfx.so => /lib/libIGGfx.so (0xb42b5000)
        libIGSg.so => /lib/libIGSg.so (0xb41ad000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb41a9000)
$ /opt/google/earth/free/googleearth-bin
sh: /opt/google/earth/free/googleearth-bin: not found


« Last Edit: January 11, 2012, 11:55:23 PM by aswjh »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #11 on: January 12, 2012, 12:28:05 AM »
This looks odd:
Code: [Select]
libQtCore.so.4 => /lib/libQtCore.so.4 (0xb7389000)
..the Qt libs in the qt-4.x-base extension are in /usr/local/lib?

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #12 on: January 12, 2012, 12:33:30 AM »
This looks odd:
Code: [Select]
libQtCore.so.4 => /lib/libQtCore.so.4 (0xb7389000)
..the Qt libs in the qt-4.x-base extension are in /usr/local/lib?

ln these files from /opt/google/earth/free/ to /lib:
  libQtCore.so.4
  libQtGui.so.4
  libQtNetwork.so.4
  libQtWebKit.so.4


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14579
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #13 on: January 12, 2012, 12:43:21 AM »
of course up to you, but my recommendation would be to use as many apps/libs from existing extensions as you can, because those are known to work with tinycore.

As an example, maybe something from the rpm is looking for a file in /etc, rather than /usr/local/etc
« Last Edit: January 12, 2012, 12:44:52 AM by Juanito »

Offline aswjh

  • Jr. Member
  • **
  • Posts: 85
Re: sh: /opt/google/earth/free/googleearth-bin: not found,what's wrong?thanks.
« Reply #14 on: January 12, 2012, 01:41:24 AM »
of course up to you, but my recommendation would be to use as many apps/libs from existing extensions as you can, because those are known to work with tinycore.

As an example, maybe something from the rpm is looking for a file in /etc, rather than /usr/local/etc

$ tce-load -i qt-4.x-base qt-4.x-webkit qt-4.x-opengl
$ ldd /opt/google/earth/free/googleearth-bin
        linux-gate.so.1 =>  (0xb78de000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb78bf000)
        libdl.so.2 => /lib/libdl.so.2 (0xb78bb000)
        libgoogleearth_free.so => /lib/libgoogleearth_free.so (0xb77c8000)
        libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0xb74ae000)
        libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0xb6a07000)
        libQtNetwork.so.4 => /usr/local/lib/libQtNetwork.so.4 (0xb68ce000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0xb68a0000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb683c000)
        libcurl.so.4 => /usr/local/lib/libcurl.so.4 (0xb662d000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb652c000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6523000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb6511000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb6426000)
        libGLU.so.1 => /usr/local/lib/libGLU.so.1 (0xb63ca000)
        librt.so.1 => /lib/librt.so.1 (0xb63c2000)
        libQtWebKit.so.4 => /usr/local/lib/libQtWebKit.so.4 (0xb50ae000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb4fec000)
        libm.so.6 => /lib/libm.so.6 (0xb4fc9000)
        libc.so.6 => /lib/libc.so.6 (0xb4ebe000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb4ea8000)
        /lib/ld-lsb.so.3 => /lib/ld-linux.so.2 (0xb78df000)
        libIGCore.so => /lib/libIGCore.so (0xb4db7000)
        libIGUtils.so => /lib/libIGUtils.so (0xb4d8f000)
        libapiloader.so => /lib/libapiloader.so (0xb4d8b000)
        libauth.so => /lib/libauth.so (0xb4d1c000)
        libbase.so => /lib/libbase.so (0xb4c2f000)
        libcommon.so => /lib/libcommon.so (0xb4b94000)
        libcommon_gui.so => /lib/libcommon_gui.so (0xb4b70000)
        libcommon_platform.so => /lib/libcommon_platform.so (0xb4b6b000)
        libcommon_webbrowser.so => /lib/libcommon_webbrowser.so (0xb4b23000)
        libcomponentframework.so => /lib/libcomponentframework.so (0xb4b1c000)
        libgeobase.so => /lib/libgeobase.so (0xb4827000)
        libgeobaseutils.so => /lib/libgeobaseutils.so (0xb47d9000)
        libge_net.so => /lib/libge_net.so (0xb478d000)
        libgoogleapi.so => /lib/libgoogleapi.so (0xb4771000)
        libmath.so => /lib/libmath.so (0xb472a000)
        libmoduleframework.so => /lib/libmoduleframework.so (0xb471c000)
        libport.so => /lib/libport.so (0xb4713000)
        libprofile.so => /lib/libprofile.so (0xb470f000)
        librender.so => /lib/librender.so (0xb46bb000)
        libreporting.so => /lib/libreporting.so (0xb46ae000)
        libsgutil.so => /lib/libsgutil.so (0xb4591000)
        libspatial.so => /lib/libspatial.so (0xb43a4000)
        libxsltransform.so => /lib/libxsltransform.so (0xb439f000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb438d000)
        libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0xb4389000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0xb4283000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb4266000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb425e000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb4244000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0xb4224000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb4221000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb421b000)
        libIGMath.so => /lib/libIGMath.so (0xb41d2000)
        libgdata.so => /lib/libgdata.so (0xb41bb000)
        libfusioncommon.so => /lib/libfusioncommon.so (0xb41b6000)
        libIGAttrs.so => /lib/libIGAttrs.so (0xb4134000)
        libIGGfx.so => /lib/libIGGfx.so (0xb3da0000)
        libIGSg.so => /lib/libIGSg.so (0xb3c98000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb3c93000)