WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: alsa.tczl + modules does not create /dev/snd/*  (Read 9121 times)

Offline Roberto A. Foglietta

  • Full Member
  • ***
  • Posts: 212
    • personal home page
alsa.tczl + modules does not create /dev/snd/*
« on: April 06, 2009, 03:59:17 PM »
I have initiated and configured the alsa sound system but /dev/snd still missing.
I think the excutable snddevices is missing and I think it shoulb be added:

Code: [Select]
wget http://www.linuxplusvalue.be/download/snddevices
sed -e "s/ln -svf /ln -sf /" snddevices >/usr/local/sbin/snddevices
chmod a+x /usr/local/sbin/snddevices
snddevices
[code]

This script need to be modified in order to work with ln from busybox.
[/code]

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #1 on: April 07, 2009, 05:27:11 PM »
Upon loading alsa.tczl and it's deps and using the command "/usr/local/etc/init.d/alsasound start" I have the /dev/snd directory:

Code: [Select]
tc@box:~$ ls /dev/snd
controlC0  pcmC0D0c   pcmC0D0p   pcmC0D1c   pcmC0D1p   timer
tc@box:~$

Is anyone else having issue with the /dev/snd not being created?

Offline earlytv

  • Newbie
  • *
  • Posts: 26
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #2 on: April 14, 2009, 04:20:57 PM »
I have /dev/snd.
I did all it says under alsa so I dont have to keep doing

sudo alsaconf

but I still do.
Make any difference I use tcz alsa?

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #3 on: April 14, 2009, 04:42:12 PM »
The tcz alsa works fine with me to start the sound automatically on boot.

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #4 on: April 14, 2009, 09:25:13 PM »
Oh, and make sure you have recently downloaded the alsa extensions as there have been changes to them recently, most recent a bug fix in the startup file.

Offline earlytv

  • Newbie
  • *
  • Posts: 26
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #5 on: April 14, 2009, 09:31:37 PM »
I have the old one installed I think, how do you get rid of something installed to update?

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #6 on: April 14, 2009, 09:34:31 PM »
If it is tcz, then the tcz-uninstall.tce extension will do it.

Offline earlytv

  • Newbie
  • *
  • Posts: 26
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #7 on: April 14, 2009, 10:14:04 PM »
Still have to do sudo alsaconf?
I have to click on 3 items during sudo alsaconf to get sound to work.
One is something about changing a file someplace?

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #8 on: April 15, 2009, 07:32:34 AM »
Does the startup script "/usr/local/etc/init.d/alsasound start" not work?

Offline earlytv

  • Newbie
  • *
  • Posts: 26
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #9 on: April 15, 2009, 02:12:17 PM »
Does the startup script "/usr/local/etc/init.d/alsasound start" not work?

No it still dont work? When I run sudo alsaconf this happens, maybe more then other systems?

(building card database
searching cards
I pick cs5535audio hit ok
configuring snd cs5535audio
modify /ect/modprobe.conf   I pick yes
preparing card for playing
run script alsasound  I pick yes)


So many things on these systems seem different?
On the 32 and 64meg solid state flash ide drives this works

root (hd0,0)
kernal /boot/bzImage  (xxxxxxxxxxxxxxxxxxx other items)

but on the 512meg solid state flash ide drives I could not get anything to boot untill I added this?

root (hd0,0)
kernal /boot/bzImage  root=/dev/hda1

the boot keeps saying cant find bzImage without it?
« Last Edit: April 15, 2009, 04:08:59 PM by earlytv »

Offline Jason W

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #10 on: April 15, 2009, 05:54:31 PM »
It seems there are other issues involved outside of alsa that I wish I could help with but I do not have the hardware such as flash ide drives..

Offline nickispeaki

  • Full Member
  • ***
  • Posts: 177
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #11 on: April 20, 2009, 08:25:53 AM »
i had issue with the /dev/snd not being created?
;-(
i haven't sound.

but some times ago i can see (with bugs) video in mplayer-nodep.... magic things!

Offline nickispeaki

  • Full Member
  • ***
  • Posts: 177
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #12 on: April 20, 2009, 08:35:34 AM »
Code: [Select]
>/usr/local/etc/init.d/alsasound
Failed to execute child process "/usr/local/etc/init.d/alsasound" (No such file or directory).
>ls  (8419)
alsasound
>ls (8419) returned '0'

>alsasound start
Failed to execute child process "alsasound" (No such file or directory).
>alsasound
Failed to execute child process "alsasound" (No such file or directory).

magic day!
alsasound is here, but emelfm and aterm doesn't run it!!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14644
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #13 on: April 20, 2009, 08:36:51 AM »
From the error below, it looks like you need to load the bash extension?

Offline nickispeaki

  • Full Member
  • ***
  • Posts: 177
Re: alsa.tczl + modules does not create /dev/snd/*
« Reply #14 on: April 20, 2009, 08:51:12 AM »
From the error below, it looks like you need to load the bash extension?

Code: [Select]
>bash
Failed to execute child process "bash" (No such file or directory).
;D  ;D  ;D  ;D

great thanks, Juanito! ;)
« Last Edit: April 20, 2009, 08:53:47 AM by nickispeaki »