WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: German kmap  (Read 3552 times)

Offline si_hussain1

  • Newbie
  • *
  • Posts: 44
German kmap
« on: June 23, 2009, 01:12:11 AM »
Hi,
   I am trying to load a keymap . I download the kmap.tce in my persistent directory and added the loadkmap line in the bootlocal.sh as instructed in FAQS. But, the keymap doesnt seem to change.
  I added "loadkmap < /usr/share/kmap/gr.kmap" .
But after bootup, the keys are in qwerty only. They are supposed to be in the german format right?
   I also tried fr.kmap, fr-latin1.kmap, but it didnt work. Please let me know as to how to change the keyboard settings. Also, is it possible to add the support for other languages in GUI.

Offline si_hussain1

  • Newbie
  • *
  • Posts: 44
Re: German kmap
« Reply #1 on: June 24, 2009, 11:04:43 PM »
Hi,
  Any suggestions regarding this?

Offline SvOlli

  • Full Member
  • ***
  • Posts: 192
  • Linux Developer
Re: German kmap
« Reply #2 on: June 25, 2009, 08:30:45 AM »
I tried the following:
1. Starting up as normal.
2. Installed kmaps.tce.
3. Shut down with "Exit To Prompt"
4. Ran "sudo loadkeys < /usr/share/kmap/de-latin1.kmap"
5. Run "startx" to fire up Xvesa again.

And I got a working German layout. I assume your problems are either a missing "sudo" or using the wrong keymap (gr is Greece not German).

Offline frimical

  • Jr. Member
  • **
  • Posts: 63
Re: German kmap
« Reply #3 on: June 25, 2009, 11:04:22 AM »
before doing 5) you can test your keyboard, it would have been changed accordingly... and when you got the right map for your keyboard it will be same for x too.

Offline Friedl

  • Newbie
  • *
  • Posts: 22
Re: German kmap
« Reply #4 on: June 30, 2009, 11:24:50 PM »
BTW - the documentation http://www.tinycorelinux.com/faq.html#bootcodes says:
Code: [Select]
tinycore kmap=us                    Choose Keyboard (currently us only)
Could someone correct this to
Code: [Select]
... (currently us only unless kmap.tce is installed)
or something like this?

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7344
  • Founder Emeritus
Re: German kmap
« Reply #5 on: July 01, 2009, 10:38:52 AM »
Updated! Thanks for suggestion.
10+ Years Contributing to Linux Open Source Projects.

Offline Friedl

  • Newbie
  • *
  • Posts: 22
Re: German kmap
« Reply #6 on: July 02, 2009, 11:47:59 AM »
Cool, thanks a lot! My son has taken some TinyCore CDs to school and he and his friends use them to play around, but they don't have the english keymap in their head, so this one is a very useful feature ;)

Offline adszhu

  • Newbie
  • *
  • Posts: 15
Re: German kmap
« Reply #7 on: September 08, 2009, 01:20:19 AM »
Friedl,
how could You finally manage to boot german keymap? I loose my keymap each time TC boots...

Offline chattrhand

  • Newbie
  • *
  • Posts: 48
Re: German kmap
« Reply #8 on: January 10, 2011, 03:28:28 AM »
hi tinyusers,
actually I am using TC 3.4.1 and also had the problem to set my keyboard to german.
Trying the same way as SvOlli I found that may the modifications of kmaps.tce should be followed by modifications here (line 4 only)

  1. Starting up as normal.
  2. Installed kmaps.tce.
  3. Shut down with "Exit To Prompt"

  4. Ran "sudo loadkmap < /usr/share/kmap/qwertz/de-latin1-nodeadkeys.kmap

  5. Run "startx" to fire up Xvesa again.

This may not be a problem for Experienced Linux Users, but for newbies it is.
Und ewig grĂ¼sst das Murphy-Tier

Offline TaoTePuh

  • Full Member
  • ***
  • Posts: 172
Re: German kmap
« Reply #9 on: January 10, 2011, 04:20:36 AM »
Maybe you wanna try the bootcode:

Code: [Select]
kmap=de

Offline jls_legalize

  • Hero Member
  • *****
  • Posts: 1335
    • Core17
Re: German kmap
« Reply #10 on: January 10, 2011, 05:08:27 AM »
the right boot code would be
kmap=qwerz/de or something like this
legalize them                                     ThisIsNotlYnuCsfrOmscR-Etch

Offline TaoTePuh

  • Full Member
  • ***
  • Posts: 172
Re: German kmap
« Reply #11 on: January 10, 2011, 06:34:14 AM »
"kmap=de" works well for me ...

Offline jls_legalize

  • Hero Member
  • *****
  • Posts: 1335
    • Core17
Re: German kmap
« Reply #12 on: January 10, 2011, 06:39:26 AM »
do u have the latest kmaps.tcz ?
legalize them                                     ThisIsNotlYnuCsfrOmscR-Etch

Offline TaoTePuh

  • Full Member
  • ***
  • Posts: 172
Re: German kmap
« Reply #13 on: January 10, 2011, 07:45:40 AM »
Yes - TC 3.4.1 with updated tces

Offline TaoTePuh

  • Full Member
  • ***
  • Posts: 172
Re: German kmap
« Reply #14 on: January 10, 2011, 09:04:35 AM »
I retract!
"kmap=de" seems to work for me but it is my X- and locale config. "Exit to prompt" brings it to light: it does not work ...

Correct settings (as jls_legalize already wrote) are for e.g.

Code: [Select]
qwertz/de
qwertz/de-latin1
qwertz/de-latin1-nodeadkeys

Thanks for the correction.