WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore14.0 Beta  (Read 22953 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: piCore14.0 Beta
« Reply #30 on: May 21, 2023, 10:11:40 AM »
If it works, I don't know if Juanito wants to change the  .dep  file or rename
enchant.tcz  to  enchant2.tcz  to match the other Tinycore repos.

dep file adjusted - I guess there wasn't an enchant[1] in aarch64..

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11321
Re: piCore14.0 Beta
« Reply #31 on: May 21, 2023, 10:18:59 AM »
Hi aus9
I don't have a pi but I tried it under TC14 x86_64 and could not
reproduce your results.

Try it again but start it from a terminal like this:
Code: [Select]
filetool
I added  /etc/fstab  to my backup:
Code: [Select]
root
etc/firefox
etc/X11
etc/fstab

When I deleted the entry, this message showed up in the terminal:
Code: [Select]
sed -i '4d' /opt/.filetool.lst
30

Translation:
The  sed  command says to remove line number 4 from /opt/.filetool.lst
The  sed  command had a length of 30 characters.

See if an error message is also displayed.

Maybe  busybox sed  broke.
Maybe you have  sed.tcz  installed and it's causing the issue.

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #32 on: May 22, 2023, 04:37:10 AM »
Hi Paul_123
yes pciutils was updated before posting

Hi Juanito
tce-load -w abiword works as expected

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #33 on: May 22, 2023, 04:53:36 AM »
Hi Paul_123

I attempted to load flwm and flwm_topside
both fail at console command startx
both complain they are missing /etc/sysconfig/Xserver

Maybe they need xorg-server as a dep?
« Last Edit: May 22, 2023, 05:01:43 AM by aus9 »

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #34 on: May 22, 2023, 04:59:28 AM »
Hi Rich

I am sad to say....your command has revealed that somehow I had changed /opt because the error message in running filetool was
something like sed can not create /opt/.filetool.lstiVSG* permission denied

To anyone having to read my dribble....I am going to take a break....do a fresh install and make notes on every change I make, not what I download as TCEs are pristine state so I will copy that tce dir to a usb stick etc. The fact that no-one else has reported strange permissions etc means its just me.
I accept that so must move on

thanks to Rich I now have  a better cmdline.txt with the correct syntax for no swap file and persistent home.

Yippee!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: piCore14.0 Beta
« Reply #35 on: May 22, 2023, 05:17:19 AM »
There’s a choice between Xorg and Xorg-3d in piCore - for me it makes more sense to say Xorg, flwm, aterm and wbar are required as a minimum for a gui. This is what has been done with the TC meta extension in the armv* repos.
« Last Edit: May 22, 2023, 05:22:13 AM by Juanito »

Offline mortegai

  • Jr. Member
  • **
  • Posts: 55
Re: piCore14.0 Beta
« Reply #36 on: May 27, 2023, 02:36:57 PM »
EEK then the seg fault is something I have done....I will need to ponder my changes. I have made some. As pcmanfm is a GUI I will need a desktop so I will try to see over the weekend what I have done wrong. Or not bother and just do an update of pcmanfm.

Hi aus9,
I have installed your pcmanfm update (v1.3.2) and everything seems to work correctly

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #37 on: May 27, 2023, 08:09:55 PM »
Hi mortegai and anyone with the same warning
your post 14,
Quote
The directory '~/Templates' doesn't exist, ignoring it

The easiest way is just make the directory
Code: [Select]
mkdir $HOME/Templates
I can't remember if I was that smart of if I loaded xdg-user-dirs and ran
Code: [Select]
xdg-user-dirs-updatewhich is supposed to look at what dirs you want at /usr/local/etc/xdg/user-dirs.default
YMMV

For me, both pcmanfm and lxterminal open with no warnings launched by terminal

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #38 on: May 29, 2023, 03:39:47 AM »
I have got a video crash which is repeatable. Initially I was loading libv4l and just before the crash, I saw that alsa-modules-KERNEL had loaded then the crash occurred.

Being a dumbo I rebooted and repeated to get same result. Not being used to RPi I could not get another getty.

2) Checking the deps and knowing the last to load as the alsa-modules on a fresh reboot I only loaded
graphics-KERNEL and that crashed.

3) on next reboot I put graphics-KERNEL.tcz at the bottom of my boot list and rebooted
this time I get to console/getty prompt with warning fail in waitforx

Then at console prompt I typed startx.....and desktop launches,  is what I am typing on now (jwm)

4) then
Code: [Select]
tce-load -i libv4l2
v4l-dvb-6.1.25-piCore-v8.tcz: OK
libv4l2.tcz: OK

5) Because I got to the console prompt I have kept the dmesg in case anyone finds it useful
https://www.dropbox.com/s/rsrbtcuoulfjp1m/dmesg.txt

thanks for reading

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 1154
Re: piCore14.0 Beta
« Reply #39 on: May 29, 2023, 10:15:43 AM »
I don’t see any error messages in what you posted.   Or are you just getting waitforX failing?

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #40 on: May 29, 2023, 07:27:53 PM »
Hi at section (3) I do not get a desktop but thewaitforX failing

I too could not see any errors in that dmesg but my skills with Rpi are still low.

Maybe someone else with a desktop, happy to use the power switch to turn off and on to reboot could confirm their desktop fails too in loading
graphics-KERNEL?

2) Is it worthwhile in making beta2 images etc to mod /etc/inittab to allow one more getty?

that way if a member loads something that causes a crash ....black screen output....they can get a second getty and run startx?

cheers
« Last Edit: May 29, 2023, 07:31:45 PM by aus9 »

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 1154
Re: piCore14.0 Beta
« Reply #41 on: May 29, 2023, 10:03:20 PM »
Images have ssh enabled by default.  Use ssh to see what is going on..

I have a feeling this is a race condition in the audio not loading before the vc4 driver inits.  During alpha, we needed to add the cma shared memory driver to the initrd to get this to work reliably, but beta 1 had newer firmware that seemed to work fine without.

If this is the case, when you run dmesg from ssh, it will show there is not a framebuffer created.

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #42 on: May 30, 2023, 12:54:33 AM »
Hi Paul_123

I removed graphics-KERNEL from my boot list and rebooted and used TC64 to load graphics-KERNEL
in TC64 its shows both alsa and graphics KERNEL TCEs loading  but monitor on RPi goes black as prev reported.

2) I am not good as scp and have no plans to learn at this stage so I rebooted.....and for reasons I can not explain.....my persistent home dir was gone. PUFF so much for me thinking I knew what I doing  ;D
I have just spotted that partition 1 needs a fsck. I get on to that later and my bootcode I got from Rich in another post....I will have to change that because
Quote
[    0.000000] Unknown kernel command line parameters "nortc noembed nozswap opt=mmcblk0p2 home=mmcblk0p2", will be passed to user space
[    3.115230] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck..

3) anyhow here is link to dmesg created by ssh command on TC64
https://ln5.sync.com/dl/3b16fd620/r5hrb6fs-cfqi4cfz-ntdicqc3-c7rqk6ch

Altho others do not know.....I chose sync for its 5G free storage but it allows only 3 links to be active any point in time. So link will be deleted when I need a spare link......but you have the piCore64-14.x link which I am keeping.

If you do not mind, as I will be rebuilding my home dir here is dir link (as I lost that link and had to use sync to regain it)
https://ln5.sync.com/dl/1e5a26870/mijx95vj-pfbcqp6p-yevtqeqf-jd95g68b

3)
Code: [Select]
cat dmesg-ssh.txt | grep framebuffer
[    1.377773] simple-framebuffer 3e4e0000.framebuffer: framebuffer at 0x3e4e0000, 0x6e7000 bytes
[    1.377795] simple-framebuffer 3e4e0000.framebuffer: format=a8r8g8b8, mode=1824x984x32, linelength=7296
[    1.385816] simple-framebuffer 3e4e0000.framebuffer: fb0: simplefb registered!

end of dmesg may be useful
Quote
[   13.792413] bcmgenet fd580000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[  127.794271] snd_bcm2835: module is from the staging directory, the quality is unknown, you have been warned.
[  127.811045] bcm2835_audio bcm2835_audio: card created with 8 channels
(gap by me)
[  128.709351] vc_sm_cma: module is from the staging directory, the quality is unknown, you have been warned.
[  128.710512] bcm2835_vc_sm_cma_probe: Videocore shared memory driver
[  128.710533] [vc_sm_connected_init]: start
[  128.750170] [vc_sm_connected_init]: installed successfully
[  128.904083] [drm] Initialized v3d 1.0.0 20180419 for fec00000.v3d on minor 0
[  128.913311] Console: switching to colour dummy device 80x25
[  128.942189] vc4-drm gpu: bound fe400000.hvs (ops vc4_hvs_ops [vc4])
[  128.943842] Registered IR keymap rc-cec
[  128.943970] rc rc0: vc4-hdmi-0 as /devices/platform/soc/fef00700.hdmi/rc/rc0
[  128.944087] input: vc4-hdmi-0 as /devices/platform/soc/fef00700.hdmi/rc/rc0/input7




« Last Edit: May 30, 2023, 12:57:57 AM by aus9 »

aus9

  • Guest
Re: piCore14.0 Beta
« Reply #43 on: May 30, 2023, 01:16:21 AM »
I am now thinking the lost of home was because I could not recover within RPi from the blank screen so I used a power off power on to reboot.
I am now thinking I will save /etc/inittab once I resolve a better home bootcode

Offline mortegai

  • Jr. Member
  • **
  • Posts: 55
Re: piCore14.0 Beta
« Reply #44 on: May 30, 2023, 05:48:26 AM »
...
I have a feeling this is a race condition in the audio not loading before the vc4 driver inits.  During alpha, we needed to add the cma shared memory driver to the initrd to get this to work reliably, but beta 1 had newer firmware that seemed to work fine without.

Perhaps the cause may be the softdep between the vc4 and snd-soc-hdmi-codec modules, as indicated in http://forum.tinycorelinux.net/index.php/topic,26080.msg167351.html