WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: how to disable all built-in screensavers  (Read 697 times)

Offline GNUser

  • Hero Member
  • *****
  • Posts: 1378
how to disable all built-in screensavers
« on: March 31, 2023, 02:24:24 PM »
I have an X230 ThinkPad with Coreboot, running TCL14-beta x86_64 with Xorg-7.7 and fluxbox.

No screensaver or power manager extension is loaded. Nevertheless, I've noticed that after exactly 10 minutes of inactivity, a fullscreen, opaque, white and vaguely checkerboard overlay appears over my desktop. I'll attach a screenshot (it's not much to see). Touching any key makes it disappear. It doesn't matter if laptop is plugged in or running on battery power.

I already run these commands at every boot, to prevent this kind of shenanigans from Xorg:
Code: [Select]
xset s off
xset -dpms
xset s noblank

There must be another, more sneaky screensaver/powersaver hiding somewhere. Can someone please help me identify it and disable it?

« Last Edit: March 31, 2023, 02:38:07 PM by GNUser »

Offline GNUser

  • Hero Member
  • *****
  • Posts: 1378
Re: how to disable all built-in screensavers
« Reply #1 on: March 31, 2023, 02:58:37 PM »
It was X's fault, after all. Running the above commands a bit later in boot process (sleep 1) fixed the problem.

Sorry for the noise.

Offline GNUser

  • Hero Member
  • *****
  • Posts: 1378
Re: how to disable all built-in screensavers
« Reply #2 on: March 31, 2023, 04:59:31 PM »
This is the working script that is called from ~/.X.d/
Code: [Select]
#!/bin/sh

sleep 1

# completely disable X's screensaver and DPMS "features":
xset dpms 0 0 0
xset s noblank
xset s off
xset -dpms

ref: https://wiki.archlinux.org/title/Display_Power_Management_Signaling

Problem solved.