WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved]: wifi.tcz and 0 quality and failed to connect  (Read 1064 times)

aus9

  • Guest
[Solved]: wifi.tcz and 0 quality and failed to connect
« on: March 08, 2023, 12:01:48 AM »
Hi

I am normally on ethernet so have no plans to go to wifi but I recently updated 8188eu for TC64 and attempted to connect to wifi

Code: [Select]
sudo wifi.sh
Select Wifi Network

    ESSID                  Enc Qual Channel Type
 1. ZEVERSOLAR-1839         on   0   6 WPA
 2. Gorgon26               on   0   5 WPA
snip

Enter selection ( 1 - 8 ) or (q)uit: 2
Enter password for Gorgon26 (8 to 63 characters): <checked against phone pw is good>
Sending credentials to requested access point Gorgon26...................
Failed to connect.

I am aware wifi can have interference, distance, wrong passsphrase and lets not forget I am your local village idiot with almost zero wifi skills. Passphrase does not use any special characters....letters caps and numbers only,
9 characters

Does zero quality suggest interference, distance or usb dongle can not handle that specific channel?

2) My inference is that if the router names appear in wifi.sh then my firmware and kernel module must be working

thanks for reading
I have no rights to adjust router configs at this location.

Does failed to connect eliminate or point to a specific issue other than not getting an inet address
« Last Edit: March 10, 2023, 08:17:19 AM by Rich »

Offline core-user

  • Full Member
  • ***
  • Posts: 191
  • Linux since 1999
Re: wifi.tcz and 0 quality and failed to connect
« Reply #1 on: March 08, 2023, 12:42:03 AM »
DHCP? - maybe it uses another protocol(?)
AMD, ARM, & Intel.

aus9

  • Guest
Re: wifi.tcz and 0 quality and failed to connect
« Reply #2 on: March 10, 2023, 02:50:13 AM »
thanks core-user.

I got some extra help from GNUser and we both agreed from a diff test...my driver was bad.
I found a new upstream source

now wifi connects
Code: [Select]
Sending credentials to requested access point Gorgon26..........
deleting routers
adding dns 10.0.0.138

I have some more testing to do....but will update my kernel module soonish

aus9

  • Guest
Re: wifi.tcz and 0 quality and failed to connect
« Reply #3 on: March 10, 2023, 02:51:51 AM »
Hi Rich
please mark as solved

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11286
Re: [Solved]: wifi.tcz and 0 quality and failed to connect
« Reply #4 on: March 10, 2023, 08:17:57 AM »
Hi aus9
Done.  :)