WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Sound on AMD Geode LX800  (Read 9839 times)

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #15 on: May 19, 2010, 04:11:58 PM »
@curaga

I have updated OSS.tcz but still can't seem to use 2 sound programs to access the audio device at the same time.

sudo ossdevlinks -v gives:
1 audio devices
/dev/dsp1 is the next free legacy device
/dev/dsp0: symlink -> /dev/oss/oss_geode0/pcm0 OK
1 legacy dsp device files
/dev/oss/oss_geode0/pcm0 is the default /dev/dsp device
/dev/oss/oss_geode0/pcm0 is the default dsp_out device
/dev/oss/oss_geode0/pcm0 is the default dsp_in device
/dev/oss/oss_geode0/pcm0 is the default mmap output device
1 mixer devices
/dev/mixer1 is the next free legacy device
/dev/mixer0: symlink -> /dev/oss/oss_geode0/mix0 OK
1 legacy mixer device files


and ossinfo gives:
Version info: OSS 4.1 (b 1052/200904111036) (0x00040100) GPL
Platform: Linux/i586 2.6.29.1-tinycore #1337 SMP Fri Apr 10 19:12:39 EEST 2009 (slow-poke)

Number of audio devices:   1
Number of audio engines:   2
Number of mixer devices:   1


Device objects
 0: osscore0 OSS core services
 1: oss_geode0 AMD CS5536 AC97 Controller interrupts=2378 (4550)
 2: oss_usb0 USB audio core services


Mixer devices
 0: AC97 Mixer (ALC203) (Mixer 0 of device object 1)

Audio devices
AMD CS5536 AC97 Controller        /dev/oss/oss_geode0/pcm0  (device index 0)



finally..., dmesg gives:
osscore: This processor architecture is not compatible with vmix (info=-1) - Not enabled.
oss_geode 0000:00:0f.3: PCI INT B -> Link[LNKB] -> GSI 11 (level, low) -> IRQ 11
usbcore: registered new interface driver oss_usb


do I have an alternative on this?  ???

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #16 on: May 20, 2010, 12:55:09 AM »
and also, according to OSS Wiki [Building OSSv4 from source] it states:
http://www.opensound.com/wiki/index.php/Building_OSSv4_from_source#The_Open_Sound_System_on_Linux.2Fgeode
Quote
The Open Sound System on Linux/geode

geode processors don't have the necessary floating point support for floating point arithmetic used by vmix FLOAT mode. The parameter --config-vmix=FIXEDPOINT should be used to make vmix use integer fixed point arithmetic.

should recompiling OSS be the answer to my vmix problem?

I would like to hear inputs before I try to compile OSS

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10974
Re: Sound on AMD Geode LX800
« Reply #17 on: May 20, 2010, 01:40:33 AM »
Oh, that explains everything. Vmix by default uses floating point for better sound quality.

If you haven't compiled much before, I think you should try with alsa one more time. Try the module parameters, like "modprobe snd-sb16 isapnp=off"
The only barriers that can stop you are the ones you create yourself.

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #18 on: May 20, 2010, 02:45:42 AM »
@curaga

thanks for the reply.

anyways, I have done what you suggested above and then changed mixer levels then test sound but alsa does not 'emit' sound from the device  ???

the step was: load alsa.tcz, then modprobe you suggested, then alsaconf, then alsamixer, then play a sound file. [is this correct?]


I'll maybe try to compile it then, its been a while that I have compiled

Offline mavrothal

  • Newbie
  • *
  • Posts: 43
Re: Sound on AMD Geode LX800
« Reply #19 on: May 20, 2010, 04:56:56 AM »
I'm not sure if it will help but in the OLPC XO-1 that is also using LX800/cs5535audio, all I had to do was to commend out the udev rules in /usr/local/tce.installed/alsa of alsa.tcz
eg the
Code: [Select]
#[ -e /etc/udev/rules.d/25-alsa.rules ] || sudo ln -s /usr/local/etc/udev/rules.d/25-alsa.rules /etc/udev/rules.d/25-alsa.rules > /dev/null 2>&1

# udevadm control --reload-rules 2> /dev/null
# udevadm trigger 2> /dev/null
lines.
Then ALSA was file.
[^thehatsrule^: removed, extensions policy]

BTW I have a similar problem to yours with ALSA and LX800/cs5535audio and similar error messages but in puppylinux. cs5535audio is really strange...
« Last Edit: May 20, 2010, 11:00:41 AM by ^thehatsrule^ »

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #20 on: May 20, 2010, 06:02:55 AM »
@mavrothal

great!, I'll try these tomorrow then, thanks!  :D


@all

I have compiled OSS and I have vmix now! and I'm able to run 2 audio programs simultaneously! [or more?]

Although that there were a few warnings and some oddities..., it seems fine..., but I'll post tomorrow the 'quirks' that I had when compiling.

I seem to have a good lead with my Audio on my AMD Geode Device!  :D

More Power and Thanks to the Tinycore Community!  :D

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #21 on: May 24, 2010, 06:17:09 PM »
hello all,

I'm back :)

anyways,

I can compile OSS and make it work but I can't seem to make a package out of it :(

also..., here are some messages that I have seen when I compiled it
Quote
in: configure script

Directory depends on the ALSA package which is not available
Directory depends on the SADA package which is not available

Cannot locate <stdarg.h>
Cannot locate <stddef.h>
Cannot locate <stdarg.h>
Cannot locate <stdarg.h>
Cannot locate <vorbis/vorbisfile.h>

/bin/sh: cd: line 1: can't cd to noregparm
make: *** [dep_subdirs] Error 1


in: make build

Check devices for oss_geode
cp: cannot stat `lib/libsalsa/.libs/libsalsa.so.2.0.0': No such file or directory
Warning: No libsalsa library compiled


also..., the '--prefix=/usr/local' does not work in oss 4.2?

since the '--prefix=/usr/local' did'nt work for me., what I did was issue 'make tarball' and followed the 'alternate' way of making the module.

when I load my OSS module/extension. this is what is generated:

Quote
tc@slow-poke:/mnt/hda1/data$ sudo soundon
Relinking OSS kernel modules for "2.6.29.1-tinycore SMP mod_unload 486 "
This may take few moments - please stand by...

OSS build environment set up for REGPARM kernels

    gcc
    make
    binutils
    C library headers (glibc-devel or build-essential)

Error: The above Linux package(s) seem to be missing from your system.
       Please install them and then try to install OSS again.

Please refer to the documentation of your Linux distribution if you
have problems with installing the packages.


Relinking the OSS kernel modules failed

 :-[ ???
help!

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #22 on: May 26, 2010, 08:44:58 AM »
this is the steps I've made
=> 1st
loaded up extensions: compiletc, coreutils, tar, squashfs, linux headers, gtk-dev, etc

=> 2nd
export CFLAGS="-march=i486 -mtune=i686 -Os -pipe"
export CXXFLAGS="-march=i486 -mtune=i686 -Os -pipe"
export LDFLAGS="-Wl,-O1"

=> 3rd
extracted oss source then created a separate build directory for oss [with read/write access]

=> 4th
cd to build directory and issued: /path/to/configure/script/configure --only-drv=oss_geode --config-vmix=FIXEDPOINT

=> 5th
make build

=> 6th
make tarball

=> 7th
mkdir /tmp/pkg
cd /tmp/pkg
tar -xf /tmp/OSS-tarball.bz2
cd /tmp
mksquashfs pkg/ OSS-Geode.tcz

=> 8th
saved OSS-Geode.tcz into some persistent folder and then rebooted with base only

=> 9th
loaded OSS-Geode.tcz and excuted 'soundon' and the error appears what I've added above



I know that I missed something :(..., could someone outline for me 'the' proper way compiling OSS?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10974
Re: Sound on AMD Geode LX800
« Reply #23 on: May 26, 2010, 09:09:18 AM »
After "make tarball", do a "make install", and then copy built modules from /lib/modules/... to /tmp/pkg.
The only barriers that can stop you are the ones you create yourself.

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #24 on: May 26, 2010, 11:11:55 AM »
After "make tarball", do a "make install", and then copy built modules from /lib/modules/... to /tmp/pkg.

I see..., this is what I missed :(

anyways..., the directory '/lib/modules' seems to be infested with a gazillion of files/folders :)..., how do I copy "only" 'oss geode' modules?

I'm still at work and away from my AMD Geode/Microcore unit :(

will this work finding the modules?
# make tarball
# make install
# touch /tmp/mark
# find /lib/modules -newer /tmp/mark -not -type d > /tmp/list

then copy the what is in /tmp/list to /tmp/pkg?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10974
Re: Sound on AMD Geode LX800
« Reply #25 on: May 26, 2010, 11:58:54 AM »
Yeah, a list should work; but the modules are all in a oss/ subdir, I just can't remember exactly how deep.
The only barriers that can stop you are the ones you create yourself.

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #26 on: May 26, 2010, 01:29:17 PM »
@curaga

ok, thanks! :)

I'll try the 'list' approach and this of copying the oss/ directory and sub directories.

I'll report the results when I'm able to get back to my AMD Geode unit!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14620
Re: Sound on AMD Geode LX800
« Reply #27 on: May 26, 2010, 08:29:59 PM »
will this work finding the modules?
# make tarball
# make install
# touch /tmp/mark
# find /lib/modules -newer /tmp/mark -not -type d > /tmp/list

I think:
Code: [Select]
# touch /tmp/mark
# make install
# find /lib/modules -newer /tmp/mark -not -type d > /tmp/list

..might work better

Offline s3704ssv

  • Newbie
  • *
  • Posts: 30
Re: Sound on AMD Geode LX800
« Reply #28 on: June 01, 2010, 07:12:12 PM »
Hello to All!,

Just a little more question(s) :)

I have successfully compiled OSS for my AMD Geode Unit! :)

but I need to do 'depmod -a' and 'soundon' to activate it but its not a problem I believe.

only these below bothers me:
ossmix reports:
Quote
Selected mixer 0/W
Known controls are:
Unknown mixer extension type 10551382 (Y1) (Read-only)
Unknown mixer extension type 10879063 (X1)
Unknown mixer extension type 10747994 (Y) (Read-only)
Unknown mixer extension type 10813528 (X2) (Read-only)
Unknown mixer extension type 10682454 (W) (Read-only)
Unknown mixer extension type 10616919 (X1)
Unknown mixer extension type 10485848 (Y) (Read-only)
Unknown mixer extension type 10879065 (V) (Read-only)
line [<leftvol>:<rightvol>] (currently 32:32)
line.rec ON|OFF (currently ON)
mic <monovol> (currently 0)
mic.rec ON|OFF (currently OFF)
igain [<leftvol>:<rightvol>] (currently 75:75)
aux1 [<leftvol>:<rightvol>] (currently 32:32)
aux1.rec ON|OFF (currently OFF)
spdout.enable ON|OFF (currently OFF)
spdout.adc/dac ON|OFF (currently OFF)
spdout.pro <Consumer|Professional> (currently Consumer)
spdout.audio <AUDIO|DATA> (currently AUDIO)
spdout.copy ON|OFF (currently OFF)
spdout.pre-emph ON|OFF (currently OFF)
spdout.rate <48000|44100|32000> (currently 48000)
spdout.vbit ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-src <High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 24.7 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm1 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm2 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm3 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

ossinfo reports:
Quote
Version info: OSS 4.2 (b 2002/201006020807) (0x00040100) GPL
Platform: Linux/i586 2.6.29.1-tinycore #1337 SMP Fri Apr 10 19:12:39 EEST 2009 (slow-poke)

Number of audio devices:   1
Number of audio engines:   6
Number of MIDI devices:      0
Number of mixer devices:   1


Device objects
 0: osscore0 OSS core services
 1: oss_geode0 AMD CS5536 AC97 Controller interrupts=4769 (7818)

MIDI devices (/dev/midi*)

Mixer devices
 0: AC97 Mixer (ALC203) (Mixer 0 of device object 1)

Audio devices
AMD CS5536 AC97 Controller        /dev/oss/oss_geode0/pcm0  (device index 0)

Nodes
  /dev/dsp -> /dev/oss/oss_geode0/pcm0
  /dev/dsp_in -> /dev/oss/oss_geode0/pcm0
  /dev/dsp_out -> /dev/oss/oss_geode0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_geode0/pcm0

ossdetect and ossdevlinks gives blank outputs

and attached is the 'soundon.log'

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10974
Re: Sound on AMD Geode LX800
« Reply #29 on: June 02, 2010, 04:41:21 AM »
Log looks fine, ossdetect is silent unless used with -v. If you have sound, you're free to ignore the mixer errors.
The only barriers that can stop you are the ones you create yourself.