WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: turn off tapping  (Read 7143 times)

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #15 on: October 29, 2009, 05:03:34 PM »
Thank you I will give it a try.

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #16 on: October 30, 2009, 07:34:34 AM »
First of all thanks for your "persistance" in working with me on this.
My system crashed after creating the xorg.conf file, I got it running with TinyCore norestore......
So I am back to Xorg is running synaptics.tcz is installed and no xorg.conf.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
Re: turn off tapping
« Reply #17 on: October 30, 2009, 08:02:33 AM »
If you have a synaptics touchpad and the xorg synaptics driver is loaded before you "startx", then xorg "confless" might find the driver and load it automatically and it might set SHMConfig=true.

..but I doubt it.

To check, could you have a look in /var/log/Xorg.0.log after you "startx" and search for "synaptics"- if there is no mention of "synaptics" in the log, then the driver is not loaded and synclient will not work and you will need to create an xorg.conf in order for it to work.

You might be able to create a suitable xorg.conf by doing the following after exiting xorg:
Code: [Select]
$ sudo su
# Xorg -configure

If you paste the resulting xorg.conf here, I can suggest modifications to enable synaptics.


« Last Edit: October 30, 2009, 08:06:37 AM by Juanito »

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #18 on: October 30, 2009, 12:33:11 PM »
Section "ServerLayout"
InputDevice      "Alps Touchpad"  "AlwaysCore"

Section "InputDevice"
   Identifier   "Alps Touchpad"
   Driver     "synaptics"
   Option       "Device"     "/dev/psaux"
   Option      "Protocol"   "auto-dev"
   Option      "SHMConfig"   "true"
EndSection

This is the xorg.conf file I created in etc/X11 and then added this line to opt/.filetool.lst etc/X11/xorg.conf

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
Re: turn off tapping
« Reply #19 on: October 30, 2009, 03:33:39 PM »
I don't believe that would work - if only because you would need a matching EndSection to go with Section "ServerLayout". Even then, you will probably need to add lines for your keyboard and display.

Did you try "Xorg -configure"?

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #20 on: October 31, 2009, 09:32:29 PM »
Xorg -configure result was Fatal server error.

This is the xorg.conf I used

Section "ServerLayout"
Identifier  "X.org Configured"
Screen  0  "Screen0" 0 0
InputDevice  "Alps Touchpad"  "AlwaysCore"
InputDevice   "Keyboard0"  "CoreKeyboard"
EndSection

Section   "InputDevice"
Identifier  "Alps Touchpad"
Driver  "synaptics"
Option   "Device"     "/dev/psaux"
Option    "Protocol"   "auto-dev"
Option     "SHMConfig"    "true"
EndSection

after rebooting I did not get the normal Desktop but this

xauth: creating new authority file /home/tc/.Xauthority
Network device eth0 detected DHCP broadcasting for IP
tc@box~$

Thanks again for your persistence.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
Re: turn off tapping
« Reply #21 on: October 31, 2009, 11:53:53 PM »
There are a couple of things you could try:

1. Run "Xorg -configure" again and keep a copy of the xorg.conf it creates to modify and get working.
2. Google on your machine's name and xorg.conf to get something off the web that would work.
« Last Edit: October 31, 2009, 11:56:56 PM by Juanito »

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #22 on: November 03, 2009, 03:48:41 PM »
Hallelujah! I have a parameters list with synclient, may I ask where do I add parameter entries to xorg.conf?  for example FingerPress=255 change to 400, MaxTapTime=180 and TouchpadOff=2

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
Re: turn off tapping
« Reply #23 on: November 03, 2009, 10:31:13 PM »
Like this:
Code: [Select]
Section   "InputDevice"
Identifier  "Alps Touchpad"
Driver  "synaptics"
Option   "Device"     "/dev/psaux"
Option    "Protocol"   "auto-dev"
Option     "SHMConfig"    "true"
Option "FingerPress" "400"
Option "MaxTapTime" "180"
Option "TouchpadOff" "2"
EndSection