WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: turn off tapping  (Read 7015 times)

Offline enoch

  • Full Member
  • ***
  • Posts: 122
turn off tapping
« on: October 27, 2009, 02:07:38 PM »
Loaded Xorg tried one synaptics driver after uncompressing the tarball could not make or install

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #1 on: October 27, 2009, 08:30:01 PM »
Loaded Xorg tried one synaptics driver after uncompressing the tarball could not make or install

What error messages did you get?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #2 on: October 28, 2009, 12:47:31 AM »
synaptics driver extension posted if you'd like to test it  :)

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #3 on: October 28, 2009, 03:55:10 AM »
installed the synaptics extension entered synclient -l result was Can't access shared memory area. SHMConfig disabled? My goal is to turn off tapping making an entry in xorg.conf like MaxTapTime=0, would that do it?
Thanks,
Dave

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #4 on: October 28, 2009, 04:24:51 AM »
..sorry, I posted the wrong version of synaptics.tcz by mistake.

I've posted the correct one now

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #5 on: October 28, 2009, 09:50:54 AM »
Thanks will try it tonight am I right about the MaxTapTime=0 in xorg.conf

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #6 on: October 28, 2009, 10:49:17 AM »
That could work, but there's another setting with a value of 0, 1 or 2 which will turn off tapping when set to 2 - I can't think of the setting name right now, but it should be obvious from "synclient -l"

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #7 on: October 29, 2009, 03:07:37 AM »
Go it:
Code: [Select]
TouchpadOff = 0,1,2

0 Touchpad is enabled
1 Touchpad is switched off
2 Only tapping and scrolling is switched off

GuestMouseOff = 0,1

0 enabled
1 off

..and now for the first time in xorg I can have either only the touchpad enabled or only the pointing stick enabled or both  :)

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #8 on: October 29, 2009, 03:41:39 AM »
uninstalled and reinstalled the synaptics extension synclient -l still results with Can't access shared memory area. SHMConfig disabled?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #9 on: October 29, 2009, 03:46:43 AM »
..just to be sure, did you create a suitable entry in xorg.conf loading the synaptics driver?

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #10 on: October 29, 2009, 09:22:27 AM »
 I installed the extension rebooted and then tried synclient -l are you saying xorg.conf needs to be created after the download?

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #11 on: October 29, 2009, 09:25:37 AM »
what would the entry be in xorg.conf to load the driver?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #12 on: October 29, 2009, 09:51:19 AM »

Offline enoch

  • Full Member
  • ***
  • Posts: 122
Re: turn off tapping
« Reply #13 on: October 29, 2009, 10:55:26 AM »
sorry I don't know what to do with that posting, what entry is needed in xorg.conf to setup the driver so synclient -l will yield info?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14634
Re: turn off tapping
« Reply #14 on: October 29, 2009, 11:15:27 AM »
You need to have this section in its entirety:
Code: [Select]
Section "InputDevice"
Identifier "Alps Touchpad"
Driver  "synaptics"
Option "Device"  "/dev/psaux"
Option "Protocol" "auto-dev"
Option "SHMConfig" "true"
EndSection

..although only this line enables synclient:
Code: [Select]
Option "SHMConfig" "true"
..and the "ServerLayout" section needs this line:
Code: [Select]
InputDevice "Alps Touchpad"  "AlwaysCore"