WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: How to change default sound card in ALSA  (Read 399 times)

Offline tcl_user5

  • Newbie
  • *
  • Posts: 34
How to change default sound card in ALSA
« on: April 28, 2024, 12:42:05 PM »
I am using Corepure64.

I am not getting sound. My sound card is at sr no 1 whereas the default is set to 0. (Confirmed with aplay).
I want to change the default in /usr/local/etc/alsa/alsa.conf. but I am unable to do so as it is a read only file. I tried saving it as alsa1.conf and subsequently renaming it but that doesn't work.

I routinely do this setting on other distros so I am quite sure about the sound card and the required setting.

How do I change the default.sound card to 1?



Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11282
Re: How to change default sound card in ALSA
« Reply #1 on: April 28, 2024, 05:14:07 PM »
Hi tcl_user5
... I want to change the default in /usr/local/etc/alsa/alsa.conf. but I am unable to do so as it is a read only file. ...
You can make it writable like this:
Code: [Select]
sudo busybox cp /usr/local/etc/alsa/alsa.conf /usr/local/etc/alsa/

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14619
Re: How to change default sound card in ALSA
« Reply #2 on: April 29, 2024, 12:20:07 AM »
You can also do something analogous to this before loading alsa:
Code: [Select]
cat /etc/modprobe.conf
# /etc/modprobe.conf: Modprobe config file.
options snd_hda_intel index=1

..where you substitute the driver your sound card uses for "snd_hda_intel"