WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Recent versions of PHP need PCRE2 >= 10.39 for preg_match and preg_replace  (Read 353 times)

Offline adb014

  • Newbie
  • *
  • Posts: 16
The PHP packages after PHP 7.4 need a recent version of PCRE as discussed  in https://stackoverflow.com/questions/70040287/php7-4-preg-replace-compilation-failed-unrecognised-compile-time-option-bi. The dependancy of php in tinycore on PCRE2 version 10.32 means that the preg_match and preg_replace functions are broken. This further means that php_composer is also broken, so any developpement of PHP code (not its use unless it uses preg_match and preg_replace with certain patterns) is broken.

Could the dependency of PHP-8.2 at least  be updated to use pcre21042 ?

Offline andyj

  • Hero Member
  • *****
  • Posts: 1023
PHP 8.1, 8.2, and 8.3 have been updated for TC 15, I just haven't uploaded them yet. I have a lot of info files to update, maybe I can get them done this weekend. BTW, PHP 7.4 and 8.0 are EOL and won't compile with openssl-3 so they won't be updated.