WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Getting kernel files ready for nvidia proprietary drivers installer  (Read 4994 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14613
Re: Getting kernel files ready for nvidia proprietary drivers installer
« Reply #15 on: May 05, 2023, 08:40:20 AM »
My current difficulty is creating the nvidia tcz. I'm currently trying to keep track of all files created/moved by the installer but it's been an almost impossible task.

You could check if nvidia supports the $DESTDIR install method.

..failing that, then:
Code: [Select]
touch mymarker
sudo make install
sudo find / -not -type 'd' -cnewer mymarker | grep -v "\/proc\/" | grep -v "^\/sys\/" | tee files.txt
vi files.txt
..there will be a few files in files.txt that are obviously not needed and can de removed from the list.
« Last Edit: May 05, 2023, 10:04:16 AM by Juanito »

Offline CardealRusso

  • Full Member
  • ***
  • Posts: 167
Re: Getting kernel files ready for nvidia proprietary drivers installer
« Reply #16 on: May 05, 2023, 06:45:29 PM »
Again, I'd like to thank you for your help, juanito. Not only yours but also everyone present in this topic, as

The efforts were not in vain. I confess that I had already given up, but when I finally managed to shoot, I dedicated myself.

Today I skipped going to the beach with my friends and dedicated my whole day to doing everything right. I thoroughly analyzed the coreplayer2 nvidia tcz. It took me hours with a headache until I finally discovered that the driver would not load simply because the info file was not in tce.installed. Also many problems regarding file permissions, directories (there are more than 4 directory options for the same file) and so on. tcl x11 tries to load the settings in a totally inappropriate location.

After all, I was successful.

Here it is, the proprietary nvidia driver properly working perfectly. It is possible to upgrade and add to the TCL 14.x repository. Everything is perfect!


About the 5xx driver version. I found it very disrespectful of nvidia. The 525 driver, in addition to being almost twice the size, has a loss of almost half in performance. I think you should use the 525 driver only if it's really necessary.

The 470 driver received its last update in March of this year and will probably not receive any more updates regarding support for new cards, it should only receive security updates.

The only advantage over the 525 driver would be that it is compatible with RTX 40 and onwards video cards.

It took me several days to do something that today I am able to do from scratch in just a few minutes. It is very easy to install and make the tcz, but it still takes a lot of manual work.
« Last Edit: May 05, 2023, 06:49:33 PM by CardealRusso »

Offline CardealRusso

  • Full Member
  • ***
  • Posts: 167
Re: Getting kernel files ready for nvidia proprietary drivers installer
« Reply #17 on: June 13, 2023, 12:42:50 PM »
I will leave driver 525 here for public interest.

I was able to resolve 90% of the driver issues by moving the /usr/lib folder to /usr/local/lib as many Xorg 3d dependencies overlap these nvidia files.

The coreplayer2 driver used /usr/lib (which is default in the installer) and it manually deleted the files created by Xorg 3d via tce.installed, however there are many files, not just 1 file (1 file, 2 symlinks of the same file ) as he used it.

So I found that it would be much easier to move to /usr/local/lib and I had no problems, quite the contrary, many problems were solved.
One of them was DRI2 (DRI2: failed to authenticate (caused on mpv, nvidia-settings and others)) which gave priority to libEGL from /usr/local/lib created by the libEGL.tcz package.

Also the vulkan support is working correctly, in the previous 475 driver it doesn't work because I forgot to embed 4 miserable jsons that are created in /etc by the installer. These files I moved to /usr/local/etc and with that vulkan through the GPU worked perfectly again.

The order of packages is very important, the driver must be placed before Xorg 3D.
Here is the onboot.lst needed for everything to work correctly:
Code: [Select]

firmware-nvidia.tcz is not required (at least for me)
vulkan-tools.tcz has Xorg 3d as a dependency, so it's unnecessary to mention it


Offline CardealRusso

  • Full Member
  • ***
  • Posts: 167
Re: Getting kernel files ready for nvidia proprietary drivers installer
« Reply #18 on: August 03, 2023, 08:35:53 AM »
Driver version 535.86.05 here: https://drive.google.com/file/d/1foocZjgid_Tt1bJFrCWa8tagelWRFq55/view?usp=drive_link

It was a little painful to get it working because the proprietary kernel refuses to compile in the current version of TinyCore, so the best solution was to use the open source version: https://github.com/NVIDIA/open-gpu-kernel-modules

To work correctly, you need to add nvidia.NVreg_OpenRmEnableUnsupportedGpus=1 in the boot options in grub.cfg, otherwise it won't work.

To get nvenc to work on ffmpeg is also pretty easy, you just need to make & sudo make install  https://github.com/FFmpeg/nv-codec-headers and compile current ffmpeg without anything special, as it will be enabled when detected  https://github.com/FFmpeg/FFmpeg/

The first run needs to be with sudo in ffmpeg, otherwise it will return an error. subsequent ones don't need sudo.

Offline CardealRusso

  • Full Member
  • ***
  • Posts: 167
« Reply #19 on: May 24, 2024, 08:02:03 AM »
This is probably the most competent I've done so far.

Everything works correctly, without error or warning, as long as I run

...Try putting this in your ~/.profile (or ~/.xsession or the like), backing up your files, and rebooting:
Code: [Select]
export XDG_RUNTIME_DIR=/tmp/$(id -u)-runtime-dir...

I identified a symlink problem in the gbm, which may have been responsible for preventing wayland from running? The proprietary kernel apparently (the installer decides between the proprietary and the open-source without any information) was compiled successfully and without problems.

graphics-kernel is required before, libvulkan is recommended after.

a few prints:

Unfortunately I don't have any buildscript, a lot of manual work.