WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] Blueman error in Pi-400, picore-13.0.3  (Read 2935 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
Re: Blueman error in Pi-400, picore-13.0.3
« Reply #15 on: July 21, 2022, 10:49:50 AM »
Did you check that the graphics-KERNEL extension is loaded before the audio/bluetooth extensions?

Are you using kms or fkms?

There might be a difference between the RPi4 and Pi-400, but using kms I am able to swap between hdmi and bluetooth audio without problems and without anything special in config.txt.

Edit: from your onboot.lst, you don’t appear to be loading graphics-KERNEL at all.
« Last Edit: July 21, 2022, 11:27:30 AM by Juanito »

Offline tcl_user5

  • Newbie
  • *
  • Posts: 34
Re: Blueman error in Pi-400, picore-13.0.3
« Reply #16 on: July 23, 2022, 10:08:13 AM »
I figured out that the issue of being unable to toggle between HDMI and Bluetooth audio was occurring due to a browser issue. Toggling does NOT work in Firefox Nightly 91.7.0 ESR (which I was consistently using) and audio is outputted only to HDMI. When I shifted to Epiphany, it started working.  I am now able to get audio on paired bluetooth headphones. I am attaching the screenshots with Epiphany (working) and Firefox Nightly (not working).

Its working even without loading graphics-KERNEL at onboot (or later) and even after commenting out dtoverlay=vc4-fkms-v3d-pi4 in config.txt.

Subsequently, I checked on x86_64. Toggling between audio streams works in newer versions of Firefox (102.0.1). So, it seems to be an issue with older Firefox versions. Wonder if there is any workaround for this..... Chromium based browsers like Brave also work properly .

Kindly mark the issue as solved.

Thanks @ Juanito for your patience in suggesting various checks. Important learning point was the need for running various startup commands to enable bluetooth in RPi

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11319
Re: [Solved] Blueman error in Pi-400, picore-13.0.3
« Reply #17 on: July 23, 2022, 12:11:55 PM »
Hi tcl_user5
... Kindly mark the issue as solved. ...
Done. :)