WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] how to set country and make it visible to wifi drivers?  (Read 747 times)

Offline GNUser

  • Hero Member
  • *****
  • Posts: 926
As you may know, my home's wireless router is actually a laptop running TCL13.1 Pure64. I'm trying to upgrade my network from 2.4 GHz to 5 GHz. My new wireless USB adapter (AWUS036ACHM) supports 5 GHz frequencies but I think it can only use them if it can verify that the requested frequency is allowed in my country.

The trouble is that the country code seems to be unset, which results in the adapter not being able to use any of the 5 GHz frequencies:
[forum error - see attached]

I describe the problem in more detail here: https://github.com/morrownr/USB-WiFi/issues/84

Please, how do I set the country on a TCL box, and how do I make that setting visible to wifi drivers (e.g., nl80211)?
« Last Edit: July 03, 2022, 04:20:25 AM by Rich »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: how to set country and make it visible to wifi drivers?
« Reply #1 on: July 02, 2022, 05:40:14 PM »
Hi GNUser
According to this:
https://unix.stackexchange.com/questions/253933/wifi-iw-reg-set-us-has-no-effect
You should be able to do it like this (probably needs sudo):
Code: [Select]
iw reg set US
It also shows how to set it when loading the  cfg80211  driver.

Offline GNUser

  • Hero Member
  • *****
  • Posts: 926
Re: how to set country and make it visible to wifi drivers?
« Reply #2 on: July 02, 2022, 07:17:06 PM »
Thanks to your tip I discovered this linux kernel boot parameter: cfg80211.ieee80211_regdom=US

Unfortunately, after a reboot it still doesn't work. It seems that for the parameter to work, some kind of regulatory database is needed but is missing from my system and not available in the repository. [forum error, see attached]

Offline GNUser

  • Hero Member
  • *****
  • Posts: 926
Re: how to set country and make it visible to wifi drivers?
« Reply #3 on: July 02, 2022, 07:38:33 PM »
Kernel seems to rely on crda (this thing: https://github.com/mcgrof/crda) to make regulatory domain changes. I will try my hand at building crda but it seems a bit complicated.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: how to set country and make it visible to wifi drivers?
« Reply #4 on: July 02, 2022, 08:02:20 PM »
Hi GNUser
crda.tcz  used to be in the repo. According to this the db format changed in kernel 4.15:
https://unix.stackexchange.com/questions/459518/where-to-paste-regulatory-db-and-how

Offline GNUser

  • Hero Member
  • *****
  • Posts: 926
Re: how to set country and make it visible to wifi drivers?
« Reply #5 on: July 02, 2022, 08:29:46 PM »
Hi, Rich. I put all the  regulatory.*  files in  /lib/firmware/  directory as suggested. I still cannot set the country:
[form error. see attached]

Setting the country as in the attachment works fine in Devuan, without having to reload any kernel modules. I'm stuck.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: how to set country and make it visible to wifi drivers?
« Reply #6 on: July 02, 2022, 08:58:32 PM »
Hi GNUser
... Setting the country as in the attachment works fine in Devuan, without having to reload any kernel modules. I'm stuck.
Devuan has a persistent file system, Tinycore does not. Unless you added the  regulatory.*  files to the  rootfs , they may be
showing up too late. You might need to reload the drivers or create an additional initrd containing just the  regulatory.*  files.

Offline GNUser

  • Hero Member
  • *****
  • Posts: 926
Re: how to set country and make it visible to wifi drivers?
« Reply #7 on: July 02, 2022, 09:57:29 PM »
1. I added  /lib/firmware/regulatory.db  and  /lib/firmware/regulatory.db.p7s  to corepure64.gz
2. I added this command to top of /opt/bootlocal.sh: iw reg set US

Then I rebooted and voila, everything works as expected :o
My home wireless network is now 5 GHz. Download speeds for wireless clients increased from 30 Mbps to 90 Mbps. Rich, there's absolutely no way I could have solved this without your help. THANK YOU!
« Last Edit: July 02, 2022, 10:07:25 PM by GNUser »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: [Solved] how to set country and make it visible to wifi drivers?
« Reply #8 on: July 03, 2022, 05:24:04 AM »
Hi GNUser
If you create a separate initrd it will make it obvious there is a special modification. Plus it
is now portable so you don't have to remaster  corepure64.gz  anytime you want to test
a new release.

Create the file system:
Code: [Select]
mkdir -p tempdir/lib/firmware/
cp regulatory.db tempdir/lib/firmware/
cp regulatory.db.p7s tempdir/lib/firmware/
cd tempdir

Pack it up:
Sorry, forum error, see attachment.

Finish:
Code: [Select]
cd ..
Code: [Select]
rm -rf tempdir
cp regulatory.gz /boot

I think the syntax for loading multiple initrd files in grub2 would look like this:
Code: [Select]
initrd /boot/corepure64.gz /boot/regulatory.gz

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 842
Re: [Solved] how to set country and make it visible to wifi drivers?
« Reply #9 on: July 03, 2022, 07:06:11 AM »
I have found that as long as regulatory.db and it’s signature is loaded before your WiFi firmware/drivers.  It works fine in an extension….. at least on a rpi.  There is a regdb.tcz extension in the piCore repos.

And yes, crda is obsolete with modern kernels.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: [Solved] how to set country and make it visible to wifi drivers?
« Reply #10 on: July 03, 2022, 07:54:29 PM »
Hi Paul_123
Thanks for that. I wasn't sure whether or not any wireless components are included as part
of the base system, and this seemed like the most foolproof solution.

Offline GNUser

  • Hero Member
  • *****
  • Posts: 926
Re: [Solved] how to set country and make it visible to wifi drivers?
« Reply #11 on: July 03, 2022, 07:55:12 PM »
I can confirm that providing the files as a custom initrd works. Providing them as a custom extension works as well.

I decided to go with custom initrd plus the  cfg80211.ieee80211_regdom=US  boot parameter. Everything is working like a charm. Thanks for the help!