WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: firefox needs libXtst  (Read 1692 times)

Offline attsu

  • Newbie
  • *
  • Posts: 3
firefox needs libXtst
« on: February 07, 2022, 04:27:13 AM »
Hi,

I try to use firefox 96.0.3 via firefox_getLatest.tcz in tc 13.0, but libXtst.tcz is needed addinitonally to run firefox.

attsu

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14621
Re: firefox needs libXtst
« Reply #1 on: February 07, 2022, 06:05:13 AM »
You can add libXtst.tcz to your local copy of firefox.tcz.dep.

In the meantime I'll pm the maintainer.

Offline CNK

  • Full Member
  • ***
  • Posts: 249
Re: firefox needs libXtst
« Reply #2 on: February 08, 2022, 05:13:51 AM »
A new version (2.8) of firefox_getLatest has been submitted, though as I won't get around to upgrading to TC13 for a while it's only tested in TC12 (if the missing libXtst dep entry was the only problem with TC13 though, the new version should run just as well).

The new version of the script has a new option "-d" which disables generating the .dep file. This is handy for people who frequently upgrade Firefox and want to keep modifications they've made to the firefox.tcz.dep file (eg. inserting new firefox dependencies like this which the script isn't yet including itself).

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14621
Re: firefox needs libXtst
« Reply #3 on: February 09, 2022, 12:02:11 AM »
updated firefox_getLatest posted

There is also an updated firefox-ESR in the 64-bit repo for those that prefer alsa.