WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: udev rules.d corepure64  (Read 5690 times)

Offline Rabie

  • Sr. Member
  • ****
  • Posts: 272
Re: udev rules.d corepure64
« Reply #15 on: February 25, 2022, 03:27:46 AM »
Hi Rich,


Hi Rabie
Does your system have a Wacom tablet?

no it doesn't

anything i can do to get rid of the udev errors ?
« Last Edit: February 25, 2022, 03:29:17 AM by Rabie »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: udev rules.d corepure64
« Reply #16 on: February 25, 2022, 05:13:09 AM »
I don't see any errors - do you have any udev rules in your backup?

Offline Rabie

  • Sr. Member
  • ****
  • Posts: 272
Re: udev rules.d corepure64
« Reply #17 on: February 25, 2022, 05:46:41 AM »

error:
Code: [Select]
udevd[167]: IMPORT(builtin}: 'hwdb --subsystem=input '--lookup-prefix=libwacom:name:$attr(name}:""unknoun/etc/udev/rules.d/65-libwacom.rules:18
the errors comes from this line in  /etc/udev/rules.d/65-libwacom.rules
Code: [Select]
KERNELS=="input*", IMPORT{builtin}="hwdb --subsystem=input '--lookup-prefix=libwacom:name:$attr{name}:'"
this is the only udev rule i am using
Code: [Select]
etc/udev/rules.d/98-tc.rules

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: udev rules.d corepure64
« Reply #18 on: February 25, 2022, 06:03:45 AM »
There's a potential problem in that the tc version of udev does not use hwdb, but when I load libinput I do not see any error messages - what do you do immediately prior to seeing the error?

Offline Rabie

  • Sr. Member
  • ****
  • Posts: 272
Re: udev rules.d corepure64
« Reply #19 on: February 25, 2022, 06:30:33 AM »
There's a potential problem in that the tc version of udev does not use hwdb, but when I load libinput I do not see any error messages - what do you do immediately prior to seeing the error?

i am not doing anything to produce the error, it occurs while booting.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: udev rules.d corepure64
« Reply #20 on: February 25, 2022, 06:44:31 AM »
If you boot with the “base” boot code and then load libinput do you still see the error?

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11306
Re: udev rules.d corepure64
« Reply #21 on: February 25, 2022, 08:01:38 AM »
Hi Juanito
Just some observations:
It appears the   .rules  file did not exist prior to TC13.
Also, according to the  .list  files, libwacom.so has been at version  libwacom.so.2.6.1  since at least TC10.
The  /usr/local/tce.installed/libwacom  file also appears to be a new addition in TC13.
These files also appear to be new to TC13:
Code: [Select]
/etc/hwdb.d/65-libwacom.hwdb
/usr/local/bin/libwacom-list-devices
/usr/local/bin/libwacom-show-stylus
/usr/local/bin/libwacom-update-db

These notes apply to x86 and x86_64.

Offline Rabie

  • Sr. Member
  • ****
  • Posts: 272
Re: udev rules.d corepure64
« Reply #22 on: February 27, 2022, 09:40:36 AM »
Hi Juanito,
If you boot with the “base” boot code and then load libinput do you still see the error?

yes i just tried to load libinput with the "base" boot mode and got the errors


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: udev rules.d corepure64
« Reply #23 on: February 27, 2022, 11:14:06 AM »
The problem is that without any error messages on my hardware it’s difficult to troubleshoot.