WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] anyone used idesk recently?  (Read 2217 times)


  • Guest
[Solved] anyone used idesk recently?
« on: July 08, 2020, 10:03:27 PM »

I have built for TC64 idesk.


I have a problem.....no not that one....my Dr knows what to do  ;D

Each icon will open if and only if any previous opened app via icon is now closed.

ie if I use an autostart ~/X.d terminal, text editor, web browser etc they all work fine.

if I double click say the cpanel...its opens and works as expected
If I then double click another icon....nothing appears to happen until I close cpanel and then the second app opens.


I have some offers as I am not entirely sure what is going wrong.

1) I email a volunteer on TC64 my TCE and they check it out on their system
2) I post my build script and someone with better skills takes over if interested
3) I request a submission....but am reluctant to burden Juanito at this stage.

It may be something to do with my video AMD APU as I can not run graphical desktop unless I load Xorg.
I have tested on hackedbox, openbox and something else
---on Xorg 2d and 3d with similar results.

In any case, from various wikis I know I can launch normal desktop icons via pcmanfm.

Here is an example of the icon file for those interested.
Code: [Select]
cat .config/idesktop/exittc.lnk
table Icon
  Caption: exittc
  Command: "exittc"
  Icon: /usr/local/share/pixmaps/exittc.png
  Width: 48
  Height: 48
  X: 29
  Y: 39

thanks for reading
« Last Edit: July 09, 2020, 10:39:29 PM by Rich »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11321
Re: anyone used idesk recently?
« Reply #1 on: July 08, 2020, 11:02:42 PM »
Hi aus9
It sounds like control is not being returned to whatever responds to those  .lnk  files.

What happens if you background the command by changing this:
Code: [Select]
Command: "exittc"to this:
Code: [Select]
Command: "exittc &"


  • Guest
Re: anyone used idesk recently?
« Reply #2 on: July 09, 2020, 02:53:19 AM »
sounds reasonable, but changing all lnk files to include & have made no difference.

I should add....I need to exit to prompt to ensure I am seeing a "changed" file.

I forgot to show what file I cheated off....upstream comes with a file, I made only one change
I show yad....originally it wanted to use zenity....but when I looked at the total yad was smaller.
dialog might also be suitable but I could not get that to work properly.

table Icon
  Caption: Idesk
  Command: yad --info --text "IDESK -- Icon Desktop Manager"
  Icon: /usr/local/share/idesk/folder_home.xpm
  Width: 48
  Height: 48
  X: 359
  Y: 239

Double clicking it and other mouse actions are controlled by a config file.
for a RH mouse user double L clicks brings up a popup box,
while for all my other icon files, double clicking the icon executes the command.

PS I have idesk in my boot list  and autostarted by ~./X.d/idesk whose contents are
idesk &

So to my thinking....& is not allegedly needed by the icon syntax.

Its a puzzlement.

I think we can eliminate & by the web page too

table Icon
      Caption: Home
      ToolTip.Caption: My home
      Icon: /home/you/.idesktop/home.png
      Command[0]: nautilus /home/you
      Command[1]: nautilus /home/you/otherDir

Command [1] is for RH click for a RH mouse user, its not needed but apparently used by some,
to use a text editor to edit the file for reasons I know not.

EDIT maybe I should show the default config too?
table Config
  FontName: Arial
  FontSize: 10
  FontColor: #000000
  ToolTip.FontSize: 12
  ToolTip.FontName: Arial
  ToolTip.ForeColor: #0000FF
  ToolTip.BackColor: #FFFFFF
  ToolTip.CaptionOnHover: true
  ToolTip.CaptionPlacement: Bottom
  Locked: false
  Transparency: 50
  Shadow: true
  ShadowColor: #000000
  ShadowX: 1
  ShadowY: 1
  Bold: true
  ClickDelay: 300
  IconSnap: true
  SnapWidth: 10
  SnapHeight: 10
  SnapOrigin: BottomRight
  SnapShadow: false
  SnapShadowTrans: 200
  CaptionOnHover: false
  CaptionPlacement: bottom
  FillStyle: fillinvert
  Background.Delay: 0
  Background.Source: None
  Background.File: None
  Background.Mode: Center
  Background.Color: #C2CCFF

table Actions
  Lock: control right doubleClk
  Reload: middle doubleClk
  Drag: left hold
  EndDrag: left singleClk
  Execute[0]: left doubleClk
  Execute[1]: right doubleClk
« Last Edit: July 09, 2020, 03:05:56 AM by aus9 »


  • Guest
Re: anyone used idesk recently?
« Reply #3 on: July 09, 2020, 03:12:26 AM »
hmmm that post is getting a bit long IMHO.

Another observation, if I hover without yet opening any icons, hover reveals the name (not the executable name)

eg hover over run ....brings up a hover text called run....exe-name is flrun

2) opening an icon.....and attempting to hover over any icon....no hover effect found.

3) I am now searching for alternatives to idesk and will check out vdesk (and maybe an update)
« Last Edit: July 09, 2020, 03:22:10 AM by aus9 »


  • Guest
Re: anyone used idesk recently?
« Reply #4 on: July 09, 2020, 10:09:33 PM »

Please mark as solved.

I attempted to use a modified setbackground using xsetroot to see if that would make a diff.
I was able to set a new background but it made no diff to opening second icon.

IMHO pcmanfm will suffice plus no need to create idesk icon files when pcmanfm can launch existing XDG supported desktop files under /usr/local/share/applications.


Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11321
Re: [Solved] anyone used idesk recently?
« Reply #5 on: July 09, 2020, 10:41:17 PM »
Hi aus9
... Please mark as solved. ...