WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: White text "Boot Error" on Black Screen  (Read 2155 times)

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 390
White text "Boot Error" on Black Screen
« on: May 07, 2020, 06:30:44 AM »
This is my first time posting on a forum. Please forgive any mistakes.
I installed Coreplus from USB onto a FAT32 partition on a HDD. I installed the boot loader(syslinux) with tc-install. I configured Windows boot loader with EasyBCD to add option "Tinycore" to boot from sda5 with "Syslinux" Option. When I click on it, it says "Boot Error". The text is white and background is black. No underscore. I also checked the files. They exist in the sda5. As I don't know what to do, I installed Super Grub2 iso on my usb and booted from it. The detect Operating Systems option was not showing the Tiny Core. Hence I took the command line and typed
Code: (bash) [Select]
insmod linux
linux (hd1,msdos5)/tce/boot/vmlinuz
initrd (hd1,msdos5)/tce/boot/core.gz
I got the partition number with the print disks option. Then I got the black screen. No underscore. As I entered boot, it also showed the lines like Setting language to C, enabling swap,..etc. Please help me.

More info :
I have a 2GB USB stick on which I installed Coreplus (as I need Wi-Fi) downloaded from your site using UNetbootin.
I booted from my USB. Coreplus booted up ( 8) ). I played some time with it. And after that, I tried to install it on my HDD.
Partitions :
sda1 : Windows MBR (NTFS, bootable)
sda2 : Windows 10 (NTFS)
sda3 : Phoenix OS (NTFS)
sda4 : Some empty space (NTFS)
sda5 : Tiny Core Installation (FAT32)

Installation :
I booted from USB. Loaded Option "Tinycore with X/GUI+Wifi+Firmware". Clicked on tc-install icon, selected core.gz from USB, selected Fugal, selected sda5, ticked "Install bootloader", [Next], (did not change any boot options), ticked Wifi, ndiswrapper, all other options, Proceed. Done. Reboot.

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 390
Re: White text "Boot Error" on Black Screen
« Reply #1 on: May 15, 2020, 02:12:42 AM »
Np. I solved it myself.
Here is a solution. It might help someone. Do this after installing tc.
1) Install tc on a usb and live boot from it.
2) Connect to a wifi and get grub-2.04 from app browser
(I was actually searching for grub-0.97 as mentioned in frugal install, but it is not there in repo.)
3) Open a terminal and type
Code: (bash) [Select]
grub-install /dev/sda5
touch /tce/boot/grub/grub.cfg
Replace /dev/sda5 with the partition in which you installed tc.
4) Add these lines to grub.cfg.
Code: (bash) [Select]
menuentry "Tiny Core Linux" {
root (hd0,4)
linux /tce/boot/vmlinuz quiet showapps noswap
initrd /tce/boot/core.gz
Replace root with the partition where you installed tc.
5) Reboot.