WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] build custom kernel - login: can't set groups: Operation not permitted  (Read 4286 times)

Offline halma

  • Full Member
  • ***
  • Posts: 164
Hi

i do building the "custom" kernel like this:

getting the latest kernel source from kernel.org, older sources makes no different to me
make all related stuff what is needed to build the bzImage and modules as written on the wiki

and then i do:
Code: [Select]
mkdir /mnt/xvda1/customkernel
cd /mnt/xvda1/customkernel
copying the corepure64.gz (version 5.3) into this folder
zcat corepure64.gz | sudo cpio -id
rm corepure64.gz
sudo rm -rf lib/modules
copying the modules to the right place, "/lib/modules", from the fresh build into the corepure64 "rootfs"
find | sudo cpio -o -H newc | gzip -2 > ../corepure64.gz
cd ..
advdef -z4 corepure64.gz

copy the new corepure64.gz and bzImage->aka "vmlinuz64" to /mnt/xvda1/tce/boot

but after booting there is no autologin as before as you can see on the bottom of the screenshot

http://postimg.org/image/4opipmjqx/
i allready tried chmod 777 and chown tc:staff to the customkernel folder but i doesnt help.
the xvda1 partition is ext4
anyone knows what the problem can be ?
« Last Edit: July 13, 2014, 05:33:25 PM by halma »
1 + 2 = 6  cause  10 - 6 = 78 ;-) lol

Offline halma

  • Full Member
  • ***
  • Posts: 164
hhm i got it ...

chown -R root:root /mnt/xvda1/customkernel/usr/lib/modules/$KERNELVERSION-tinycore64

before building the new "rootfs" aka corepure64.gz

thanks
1 + 2 = 6  cause  10 - 6 = 78 ;-) lol