WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TCL Custom Resolution in Virtual Box without Guest Additions  (Read 5214 times)

Offline Carsten

  • Newbie
  • *
  • Posts: 21
Hi,

having benefitted a lot from all the information in this forum and the effort people are putting into it, I would now like to give a little bit back.  ;)

I've been looking around in this forum, but didn't find anything, which provides the way I've found. I hope, I didn't miss the obvious ...

I'm running TCL in VirtualBox and I was a bit annoyed about not being able to use the full screen resolution of the host computer (MacBook). Well, a bit of digging and, now, I've got it running. Although I've got it running in VB on OSX, it should work the same way with any other host machine running VB and, most probably, with other resolutions. The settings below refer to the MacBook's 1440x900. Other resolutions will require changes to the x and y resolutions settings accordingly.


TCL Custom Resolution in VB

Environment

The software versions used are recent ones, but not the latest ones. Nevertheless, the steps outlined below should do the job with the latest versions.

Hardware
MacBook Air, native Resolution: 1440x900

Software
Virtual Box 4.3.6 (without Guest Additions)
TCL 5.3
OSX 4.7.5


Setting up the custom Resolution
  • On the host machine, open the Terminal (OSX) or the Command Prompt (Windows)
  • Enter the following commands:
    • Note: Replace <VM Name> with the name of your machine - the quotation marks are required!
    • Note: If the vboxmanage command cannot be found, check the path to the VB directory.
Code: [Select]
vboxmanage setextradata "<VM Name>" "VBoxInternal2/UgaHorizontalResolution" 1440
vboxmanage setextradata "<VM Name>" "VBoxInternal2/UgaVerticalResolution" 900
vboxmanage setextradata "<VM Name>" "CustomVideoMode1" 1440x900x24
vboxmanage setextradata "<VM Name>" "GUI/CustomVideoMode1" 1440x900x24
  • Start your TCL virtual machine
  • In the TCL home directory, edit the .xsession file
  • Change the resolution to 1440x900x24 and save the file
Code: [Select]
/usr/local/bin/Xvesa -br -screen 1440x900x24 -shadow -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1 &
  • Reboot your TCL VM

VOILA!


Trouble Shooting

In case, it doesn't work, you might have made a mistake with the declaration of the new vboxmanage keys. They can be checked with

Code: [Select]
vboxmanage getextradata "VM Name" enumerate
Thoroughly check the lines. In case, you got something wrong, you can delete a misspelled key by re-entering the command with the misspelled key WITHOUT the value.

E.g., you misspelled VBoxInternal2:

vboxmanage setextradata "<VM Name>" "BoxInternal2/UgaHorizontalResolution" 1440

This will remove the faulty key:

Code: [Select]
vboxmanage setextradata "<VM Name>" "BoxInternal2/UgaHorizontalResolution"

References
  • Virtual Box Manual Chapter 8.26 VBoxManage getextradata/setextradata
  • Virtual Box Manual Chapter 3.12.1 Video modes in EFI
  • Virtual Box Manual Chapter 9.8.1 Custom VESA resolutions


I hope it works for you straight away.

Good Luck!

Regards

Carsten