WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [solved] Compile error related to missing Perl module?  (Read 2102 times)

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
[solved] Compile error related to missing Perl module?
« on: June 10, 2014, 02:00:04 PM »
I'm trying to compile NetSurf on Core 5.3.

The web seems to tell me it's something related to Perl but I have really no idea about that.
perl5.tcz  and  perl_xml_parser.tcz  are loaded.

I get the following error:
Code: [Select]
...
Can't locate HTML/Entities.pm in @INC (...
...
BEGIN failed--compilation aborted at utils/split-messages.pl line 235.
/tmp/netsurf-all-3.1/netsurf/utils/split-messages.pl -- line 235:
Code: [Select]
        use HTML::Entities qw(encode_entities);


Thank you.
« Last Edit: June 10, 2014, 03:26:58 PM by Misalf »
Download a copy and keep it handy: Core book ;)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7183
    • My Community Forum
Re: Compile error related to missing Perl module?
« Reply #1 on: June 10, 2014, 02:17:18 PM »
Install HTML::Entities from CPAN
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: Compile error related to missing Perl module?
« Reply #2 on: June 10, 2014, 03:25:58 PM »
Even though I didn't install  HTML::Tagset  as recommended in the readme, compilation succeeded.

Question answered.
Thanks, bmarkus!
Download a copy and keep it handy: Core book ;)