WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: moxa card not communicate  (Read 25052 times)

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #45 on: January 27, 2014, 07:26:56 AM »
Since you will also need the moxa modules just use "make"
Thanx for reply
After command make time bzImage the i enter make command am i rite

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: moxa card not communicate
« Reply #46 on: January 27, 2014, 07:31:46 AM »
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: moxa card not communicate
« Reply #47 on: January 27, 2014, 10:26:58 AM »
Moxa support just emailed their latest code to support 3.8.x kernels so will compile and send to you to try

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
moxa card not communicate
« Reply #48 on: January 27, 2014, 04:35:44 PM »
ok with a little fiddling i built the Moxa  driver for 3.8.13 and 3.0.21 kernels

Code: [Select]
tc@box:~/mxser$ make
**********************************************************************
  3.8.13-tinycore
 MOXA Smartio/Industio Family Multiport Board Device Driver ver 1.15.27
 Release Date: 2013/09/30
**********************************************************************
tc@box:~/mxser$

and loaded it
dmesg
Code: [Select]
[ 1126.497545] MOXA Smartio/Industio family driver version 1.15.27should be good to go

sent malikawan the driver to try
« Last Edit: January 27, 2014, 09:30:43 PM by coreplayer2 »

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #49 on: January 28, 2014, 12:15:35 AM »
Thanx coreplayer2 i download driver which u send to me and its working 100% with tiny core 4.7.7 and kernel version 3.0.21.
thanx again.

Malik Awan
« Last Edit: January 28, 2014, 12:17:23 AM by malikawan »

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #50 on: January 28, 2014, 12:27:05 AM »
Summary :-
I copied the driver which coreplayer2 send to me.
i convert these file to .gz format and copy these files in /lib/modules/3.0.21-tinycore/kernel/drivers/misce and then open terminal
then open a terminal and enter:
  sudo depmod -a

then load the modules:
  sudo modprobe mxser.ko
  sudo modprobe mxupcie.ko

check dmesg for errors
check also lsmod to see if loaded

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #51 on: January 28, 2014, 05:04:24 AM »
sir just tell me when i enable moxa support from kernel config after that which step use for building a new kernel and module because when i enable moxa support then save config file after this i give command make bzimage then i give command make then mxser.o and moxa.o files create in drivers/tty after this i m confusing how i create mxser.ko file plz tell me the step after make command.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14619
Re: moxa card not communicate
« Reply #52 on: January 28, 2014, 05:14:28 AM »
As mentioned in the link a couple of posts back:
Code: [Select]
$ make bzImage
$ make modules

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #53 on: January 28, 2014, 05:20:48 AM »
As mentioned in the link a couple of posts back:
Code: [Select]
$ make bzImage
$ make modules

but when i give command it will start to making all modules but i have enable only moxa support ?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14619
Re: moxa card not communicate
« Reply #54 on: January 28, 2014, 05:24:21 AM »
no, in loading config-3.8.13-tinycore, you've enabled a whole bunch of modules.

Once things have finished you only need to save the moxa modules, the others are already available in the various tinycore module extensions.

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #55 on: January 28, 2014, 05:26:34 AM »
"Once things have finished you only need to save the moxa modules,"
ok once finish then how i get only moxa module or its auto intall on my tiny core?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14619
Re: moxa card not communicate
« Reply #56 on: January 28, 2014, 05:32:46 AM »
You first do some research on where to put the moxa modules (to check where debian puts them would be a good place to start) - it should be somewhere analogous to /usr/local/lib/modules/3.8.10-tinycore/kernel/drivers/tty or similar.

Then you use gzip and advcomp to compress the moxa modules, copy them to the filesystem and make an extension of them - most, if not all, of this is explained in the wiki and I posted a link to how it was done for the wl module extension a few posts back.
« Last Edit: January 28, 2014, 05:34:56 AM by Juanito »

Offline malikawan

  • Full Member
  • ***
  • Posts: 243
Re: moxa card not communicate
« Reply #57 on: January 28, 2014, 05:37:10 AM »
sir coreplayer2 have created driver for me and i have installed alredy but i just want to know when make modules finish how i create .ko

i want to create my self if next time i need i know how to install or configure it just tel me the step plzzzzzzzzzzzzzzzzzzz
« Last Edit: January 28, 2014, 05:40:44 AM by malikawan »

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: moxa card not communicate
« Reply #58 on: January 28, 2014, 05:50:24 AM »
You have been told, several times.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: moxa card not communicate
« Reply #59 on: January 28, 2014, 05:59:18 AM »
I suspect there might be some confusion between

1. The official in-tree (tristate) driver, which as far as I understand would require recompiling the kernel with different options (boolean dependencies)
2. An out-of-tree driver which coreplayer2 aquired from vendor
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)