WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: black screen when running Xorg  (Read 3945 times)

Offline AITap

  • Newbie
  • *
  • Posts: 5
black screen when running Xorg
« on: May 03, 2009, 03:55:22 AM »
Hello! I've installed Xorg-7.4.tcel, my xorg.conf is:
Code: [Select]
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/local/lib/X11/modules"
FontPath     "/usr/local/lib/X11/fonts/misc/"
FontPath     "/usr/local/lib/X11/fonts/TTF/"
FontPath     "/usr/local/lib/X11/fonts/OTF"
FontPath     "/usr/local/lib/X11/fonts/Type1/"
FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load  "glx"
Load  "dri"
Load  "extmod"
Load  "dbe"
Load  "freetype"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option      "XkbLayout" "ru"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option     "Protocol" "auto"
Option     "Device" "/dev/input/mice"
Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
Option     "DPMS"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24

SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

When I try to start Xorg (just by typing sudo Xorg after exiting to shell), i get only black screen!
When I return to 1st console (Ctrl+Alt+F1), I see: "error: couldn't open display", so I have to ps -a | grep Xorg and kill -9 ...
What can I do to run Xorg?

Xorg.0.log is also attached.
« Last Edit: May 03, 2009, 04:29:30 AM by AITap »

Offline mikshaw

  • Sr. Member
  • ****
  • Posts: 368
Re: black screen when running Xorg
« Reply #1 on: May 03, 2009, 05:50:56 AM »
Quote
When I try to start Xorg (just by typing sudo Xorg after exiting to shell), i get only black screen!
You need to run something along with Xorg in order to make use of a desktop.  See /home/tc/.xsession as an example.  In the default file, Xvesa is run.  Try changing that to Xorg and run the "startx" command.  Startx does a few other things to prepare the system to run X, and it should solve the error.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: black screen when running Xorg
« Reply #2 on: May 03, 2009, 10:02:24 AM »
Once your Xorg is setup and has been tested via the .info file instructions, using xsetup.sh from CLI will detect Xorg and update your .xsession for you. Requires Tiny Core v1.3 or later.
10+ Years Contributing to Linux Open Source Projects.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10970
Re: black screen when running Xorg
« Reply #3 on: May 03, 2009, 12:30:37 PM »
After installing, and either modifying .xsession yourself or by using xsetup.sh just run "startx". Plain Xorg is just the base for windows to show.

A related note: since version 1.6.0 the default is "dontzap" and a black desktop; I definitely don't agree with the decision to disable zapping by default (ctrl-alt-backspace). On the first times it made me think X had hung when it really just ignored the key combo.
The only barriers that can stop you are the ones you create yourself.

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
Re: black screen when running Xorg
« Reply #4 on: May 03, 2009, 07:28:43 PM »
I definitely don't agree with the decision to disable zapping by default (ctrl-alt-backspace)

neither do i. i even hate in qemu when i can't use it.

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: black screen when running Xorg
« Reply #5 on: May 03, 2009, 07:33:04 PM »
It's possible (just see the docs I guess)