WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] Can't Install a Windows Shared Printer to CUPS  (Read 7545 times)

Offline wirelessben

  • Newbie
  • *
  • Posts: 15
[Solved] Can't Install a Windows Shared Printer to CUPS
« on: January 31, 2012, 12:13:39 PM »
With samba3, samba3-libs, cups, and firefox  installed, cups still can't see the smb protocol:

Code: [Select]
Unable to add printer:

    Bad device-uri scheme "smb"!

The backend smb symlink points to a nonexistent file:

Code: [Select]
tc@box:~$ ls -l /tmp/tcloop/cups/usr/local/lib/cups/backend/smb
lrwxrwxrwx    1 root     root            21 Oct 12 13:53 /tmp/tcloop/cups/usr/local/lib/cups/backend/smb -> [color=red]../../../bin/smbspool
[/color]
tc@box:~$ ls -l /tmp/tcloop/cups/usr/local/bin/smbspool
ls: /tmp/tcloop/cups/usr/local/bin/smbspool: [b]No such file or directory[/b]

The real smbspool file exists at /tmp/tcloop/samba3/usr/local/bin/smbspool

CUPS and Samba are running. I can use smbclient to access the windows printer.

Is this a bug?
« Last Edit: February 03, 2012, 11:08:12 AM by wirelessben »

Offline wirelessben

  • Newbie
  • *
  • Posts: 15
Re: Can't Install a Windows Shared Printer to CUPS
« Reply #1 on: February 03, 2012, 06:39:22 AM »
It is a bug, as reported in http://forum.tinycorelinux.net/index.php/topic,12482.0.html

The workaround, as Rich figured out, is to execute the following command in a terminal:

sudo ln -fs /usr/local/bin/smbspool /usr/local/lib/cups/backend/smb

Restart Samba and CUPS:
 sudo  /usr/local/etc/init.d/samba restart
 sudo  /usr/local/etc/init.d/cups restart

The option "Windows Printer via SAMBA" will show up in CUPS via http://localhost:631