WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: minitube - cannot get video info  (Read 11282 times)

Offline hiro

  • Hero Member
  • *****
  • Posts: 1228
Re: minitube - cannot get video info
« Reply #15 on: August 08, 2011, 06:09:49 AM »
I have Xorg and it still doesn't work.
I get errors about gstreamer base plugins not loaded.

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: minitube - cannot get video info
« Reply #16 on: August 08, 2011, 07:29:40 AM »
My report in reply #14 was not meant to indicate that using Xorg would resolve the issue.  It is possible that using Xorg might produce similar, but different symptoms arising from an as yet unidentified cause.

Full Xorg is not specified as a requirement by Minitube.  This is usually an indication  that Xvesa is OK.  Supplying feedback on Xvesa was an attempt to provide controlled, repeatable conditions to assist with finding a fix.  It might be possible to do something similar with Xorg.
   

Offline Arslan S.

  • Hero Member
  • *****
  • Posts: 825
Re: minitube - cannot get video info
« Reply #17 on: August 08, 2011, 10:53:32 AM »
phonon-backend-gstreamer depends on qt-4.x-opengl which of course depends on Xorg

i just did a clean base test with Xorg loaded everything is fine here

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: minitube - cannot get video info
« Reply #18 on: August 08, 2011, 12:49:58 PM »
phonon-backend-gstreamer depends on qt-4.x-opengl which of course depends on Xorg
If Minitube is incompatible with Xvesa might it be worth mentioning this in the info file and adding Xorg as a dependency?
 

Offline Arslan S.

  • Hero Member
  • *****
  • Posts: 825
Re: minitube - cannot get video info
« Reply #19 on: August 08, 2011, 01:42:33 PM »
no need to add Xorg as a dep but i agree that it worths mentioning it in the extension info

Offline hiro

  • Hero Member
  • *****
  • Posts: 1228
Re: minitube - cannot get video info
« Reply #20 on: August 08, 2011, 04:48:51 PM »
Xorg can not be added as a dependency in the .dep files because there are several of them available for the user to choose. Yeah, the .info file is for that.

Offline cast-fish

  • Hero Member
  • *****
  • Posts: 1000
  • hi there
Re: minitube - cannot get video info
« Reply #21 on: August 08, 2011, 05:19:41 PM »
after installing Xorg 7.5 minitube is working

however, my laptop now uses Xorg graphics and it's a little slugish

is it possible to return Xvesa but still have minitube working?


V.

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: minitube - cannot get video info
« Reply #22 on: August 10, 2011, 12:24:59 AM »
Hopefully, it is possible to run without adding the full weight Xorg and the slower performance it brings to older machines.
Reporting success with Xvesa.  Offering the alternative phonon-backends seems to have worked well.

Tested with minitube, phonon-backend-mplayer and Xvesa from base.  Videos display as expected.  An added advantage - it is also a much smaller download compared to Xorg and performance is much better on low-spec machines.

Starting minitube in a terminal still produces
Code: [Select]
Xlib:  extension "SYNC" missing on display ":0.0". but does not prevent anything from working.   Installing Xvesa-7.1.tcz eliminates the error message.  Is this message significant?
   

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10973
Re: minitube - cannot get video info
« Reply #23 on: August 10, 2011, 12:44:46 AM »
No, missing sync shouldn't matter.
The only barriers that can stop you are the ones you create yourself.