WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: alsa doesn't save the mixer settings  (Read 3156 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
alsa doesn't save the mixer settings
« on: April 05, 2009, 04:15:57 PM »
I followed the instructions in the alsa info file, but when I reboot all the volumes are 0 and muted
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa doesn't save the mixer settings
« Reply #1 on: April 05, 2009, 06:46:47 PM »
I noticed the same thing when I tried it now.  Looking over what gets set up, it _should_ work, but should is a big word.  I will look more into it.

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: alsa doesn't save the mixer settings
« Reply #2 on: April 06, 2009, 10:17:03 AM »
the problem is in the file usr/local/etc/init.d/alsasound at lines 173 and 252
where it should be written the correct path of amixer that is
/usr/local/bin
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: alsa doesn't save the mixer settings
« Reply #3 on: April 06, 2009, 11:22:34 AM »
Thanks!  Fixing the amixer path in line 252 allows alsa to be up and running on boot.  The command "amixer" in line 173 shouldn't cause issue as /usr/local/bin is in our $PATH, but the /usr/bin/amixer in 252 is a problem. 

I still don't have mixer settings persisting across reboots but at least alsa can be autostarted.  I will update the alsa_modules extension with the fix which will be good enough for now.  When I have time I will get mixer settings to survive a reboot.

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: alsa doesn't save the mixer settings
« Reply #4 on: April 06, 2009, 11:30:09 AM »
my mixer setting survive upon reboot, just follow the alsa info file
« Last Edit: April 07, 2009, 01:55:21 AM by jls_legalize »
dCore user