WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: soundcard doesn't remember after settting default in alsamixer  (Read 1047 times)

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 91
soundcard doesn't remember after settting default in alsamixer
« on: September 17, 2023, 11:24:45 PM »
Running TC64 with JMW.  alsamixergui set to the correct card Salyin USB, but doesn't play so I change to the correct card using alsamixer, followed by escape key.  when I type alsactl init, it displays the wrong sound source.

Code: [Select]
$: inxi -Fz | grep Audio
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  Device-2: Saiyin USB Audio driver: hid-generic,snd-usb-audio,usbhid

What am I doing wrong?, how do I blacklist the card?
« Last Edit: September 17, 2023, 11:32:19 PM by puppybyte! »

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 91
Re: soundcard doesn't remember after settting default in alsamixer
« Reply #1 on: September 18, 2023, 10:26:56 AM »
I installed pulseaudio and pavucontrol and seems to be working better.  Now after each boot I have to startup pavucontrol and disable default card and seems to work better.   Is there a way to set the pavucontrol setting so I won't have to reset each time?  or blacklist my default card?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11283
Re: soundcard doesn't remember after settting default in alsamixer
« Reply #2 on: September 18, 2023, 10:55:02 AM »
Hi puppybyte!
Maybe this is of some interest:
https://forum.tinycorelinux.net/index.php/topic,26153.0.html

aus9

  • Guest
Re: soundcard doesn't remember after settting default in alsamixer
« Reply #3 on: September 18, 2023, 06:43:48 PM »
Hi

I have updated my post linked to by Rich.
https://forum.tinycorelinux.net/index.php/topic,26153.msg170497.html#msg170497

For this method to work you need to name your bootloader.
For grub bootloader  bootcode is on the linux line.
If you are using syslinux its on the APPEND line
and is most likely going to be
Quote
blacklist=snd_hda_intel

2) Without rebooting please post full output to this command.
Code: [Select]
lsmod | grep snd
3) For only your usb device, does it need any firmware loaded?
If so it should appear at least one line higher than alsa or pulseaudio in your boot list such as onboot.lst

4) I am not a fan of pulseaudio by better do you mean sound quality?

5) My updated trick to disable HDMI will work for you whether you use alsa or pulseaudio  ;D
« Last Edit: September 18, 2023, 06:53:23 PM by aus9 »