WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Installing CorePlusOS is not working? Need help. (I am New to this distro)  (Read 4289 times)

Offline ArchitS

  • Newbie
  • *
  • Posts: 3
I have been using ubuntu and other popular distros for few months but have been a Mac and Windows 10 user most of my life. I recently came over this linux distribution and i am interested on this. I installed the CoreOS image from Tiny Core Linux's website and flashed it to my 32 GB usb drive using balena eitcher. When my USB was ready, i went to my boot menu in my laptop (Asus Vivobook) and it clicked on my "done"
bootable usb drive, but sadly it did not work as no matter how many times i clicked on it, it just did not continue to boot. I also tried using rufus to flash but encountered the same issue. Let me know what can be done.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11157
Hi ArchitS
Welcome to the forum.

...  Let me know what can be done.
Don't use third party installers:

Offline ArchitS

  • Newbie
  • *
  • Posts: 3

Thanks for a quick reply but i tried downloading Core2usb installation tool but it's in zip file? How do i flash the ISO to my USB drive on windows 10?
I tried extracting it as well but no use. Please let me know what can be done.

Offline ArchitS

  • Newbie
  • *
  • Posts: 3
Guys, i really need help.

Offline PDP-8

  • Hero Member
  • *****
  • Posts: 915
The real truth:  long gone are the days of just being able to "click-n-burn" a TC iso and have it boot with modern computers that barf on anything cd in nature.

But we do know some things:

1) Burners like Balena Etcher, Rufus and so forth DO a proper job of burning the iso's.  It is NOT THEIR FAULT.

2) The iso's themselves are not suitable for booting on modern machines, unless you use techniques on them first, like using isohybrid.  THEN, the burning tools will do exactly the same job they did before (doing exactly what they are told by the iso), but now have the ability to appear as a HDD instead of a CD to a modern computer, which modern computers don't like to boot from - either from a technical or security issue.

3) A modern machine wants to see a 64-bit iso anyway, so the only one you could would be the TinyCorePure64 versions.  With isohybrid used beforehand.

3.5) There are other ways too, like using multibooters, which rip the iso apart, and lay down their own filesystem structure, and then rely upon YOU to massage into working to meet the TC specs.

4) BUT, lets say you are successful - well, that's emulating a CD environment.  Most want to go beyond that and use a dedicated install to a "tce" rather than a "cde" environment.

Thing is, there are nifty tc installer tools available, such as tc-install-gui, but the problem there is sticks burnt by those aren't up to date enough to be bootable on modern machinery!

So - what I'm saying is that with TC and modern macinery, we've reached a point where you either have to have a lot of a-priori knowledge of how TC is supposed to work, or put in a LOT of time getting it to work, and that means you are on your own to figure out your hardware and operational specifics.  And at some point, hand-holding in the forums just won't be enough - you'll need to do work on your own.

To be honest, coming from your background, TC on modern machinery is still not a click-n-burn way to joy.  Kind of a catch-22:  If you know, then you aren't asking. :)

THIS is why the emphasis is on the end-user getting enough linux knowledge in the first place to build their own bootable sticks manually with the distribution files, using your own bootloaders and config files and so forth just to deal with the modern gear.

So this isn't any sort of "fault" with TC.  It's just that modern gear has taken the simplicity of the golden "cd" years away, and the user needs much more knowledge than they did before - even going beyond just typing in stuff from the forums and crossing fingers...

Honestly, I'd say stick to what you know, or if small is your thing, then maybe another distro, like antiX might be more suitable.
That's a UNIX book! - cool  -- Garth

Offline Sashank999

  • Sr. Member
  • ****
  • Posts: 388
Once have a look at this : https://www.zdnet.com/article/installing-linux-on-a-pc-with-uefi-firmware-a-refresher/
I used YUMI on my USB and it worked both on BIOS Laptop and UEFI Laptop.
1. Disable Secure Boot
2. Use YUMI and flash tinycore ISO with "TinyCore Option in the menu". Change to UEFI Boot.
3. Plugin and boot.
« Last Edit: August 21, 2020, 08:10:14 PM by Sashank999 »

Offline NewUser

  • Full Member
  • ***
  • Posts: 166
On Win10 you should be able to extract the core2usb zip file. What error do you get when extracting the zip? If your Asus laptop is 64-bit try CorePure64 instead of Coreplus.

Offline PDP-8

  • Hero Member
  • *****
  • Posts: 915
@NewUser - sorry, that won't work.  It is not a simple matter of being able to unarchive the burner tool.

The matter is that these tools, along with a simple unix "dd", will dutifully produce what looks like a CD onto a usb stick based upon the release iso.

The result is that modern uefi-only hardware, with secure-boot disabled of course, simply will not recognize or allow a CD - in whatever form - to boot.

The only recourse is to trick the iso into being a hybrid - using isohybrid upon the iso before using the tools, or dd.

That article is more confusing than helpful.

I've documented using Yumi-UEFI here in the forum.  To recap:  the ops uefi *ONLY* hardware would need tinycore64.  Yumi-uefi, unlike simple burners totally rewrites the iso onto a fat32 formatted stick.

But it still won't boot.  Why?  Because YUMI-UEFI introduces an error into the grub.cfg file.  It is up to the user to spot not only the proper grub.cfg amongst a forest of multiboot bootloader chains on the new stick, but correct the glaring error introduced in the filepath and fix that first.

But wait - there's more!

Once that error is fixed, one STILL needs to do things to make the stick usable.  Like move the CDE directory to the root directory of the stick, and rename it TCE.

(If you don't, then the stick will boot, but with a totally foreign filesystem structure, it can't find the CDE directory and you end up at the cli every time.)

Ideally, one should then follow up by doing a blkid of the stick, and putting that UUID back into the TC grub.cfg file.  If you know where it is in the first place.

Oh but did I mention that the Intel-NUC can stay in uefi-only mode, but has an option to enable "optical boot" without having to resort to legacy/csm?  That's not the ops machine.

This is what the op with his current laptop would have to do.  If one is not familiar with linux, and TC in general, there are plenty of opportunities to shoot oneself in the foot.

With the variety of hardware out there, and the plethora of blogs and articles that are lengthy, but leave out important details, one can see why supporting modern machines with hybrid iso's by devs would be a total nightmare.  If one knows what they are doing - fine.  If not, I think a different distro is called for.

Basically, TinyCore being a toolkit, rather than a distribution, is not something someone new can TL;DR and wing it.
« Last Edit: August 22, 2020, 02:36:25 AM by PDP-8 »
That's a UNIX book! - cool  -- Garth