WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problems with kernel compile  (Read 4280 times)

Offline MrFusion

  • Newbie
  • *
  • Posts: 1
  • Emmett "Doc" Lathrop Brown
Problems with kernel compile
« on: January 13, 2013, 12:19:34 PM »
Hi everyone! It's my first message here!  :)

I have some problems with the compiling of the kernel for the RPi. I need the drivers for my keyboard (a logitech k400) that are available as module, at first I tried to download the "piCore-modules-3.2.27.tgz" package and put in TC but I couldn't load the driver. It seems to be some kind of mismatch beetween the version of the driver and the running kernel. So I decided to recompile the kernel and include the driver (hid-logitech-dj) as built-in.

I downloaded the "piCoreKernel.tar.xz" package, extracted it, edited the .config file and launched the compile. But after a few time it gives me this error:

drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c: In function 'hcd_init':
drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c:461: error: 'INTERRUPT_VC_USB' undeclared (first use in this function)
drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c:461: error: (Each undeclared identifier is reported only once
drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c:461: error: for each function it appears in.)
make[4]: *** [drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.o] Error 1
make[3]: *** [drivers/usb/host/dwc_otg] Error 2
make[2]: *** [drivers/usb/host] Error 2
make[1]: *** [drivers/usb] Error 2
make: *** [drivers] Error 2

So I disabled the OTG driver, and tried to restart the compile but this new error occurred:
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o: In function `sdhci_spin_enable_schedule':
clkdev.c:(.text+0x9d344): undefined reference to `enable_llm'
drivers/built-in.o: In function `sdhci_reset':
clkdev.c:(.text+0x9d490): undefined reference to `enable_llm'
drivers/built-in.o: In function `sdhci_set_clock':
clkdev.c:(.text+0x9d6dc): undefined reference to `enable_llm'
drivers/built-in.o: In function `sdhci_spin_lock_irqsave':
clkdev.c:(.text+0x9d7c4): undefined reference to `enable_llm'
drivers/built-in.o: In function `sdhci_spin_unlock_irqrestore':
clkdev.c:(.text+0x9d848): undefined reference to `enable_llm'
drivers/built-in.o:clkdev.c:(.text+0x9e094): more undefined references to `enable_llm' follow

And I don't know how solve this. I'm using Debian Wheezy i386 for cross-compile. So someone can help me?
Roads? Where we're going we don't need... roads.