WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore Extension Request  (Read 7798 times)

Offline CentralWare

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 661
Re: piCore Extension Request
« Reply #30 on: January 06, 2021, 07:39:25 PM »
@Paul_123 : Dead, as in, no longer supported - today and future releases? (I'm updating our local repo; versions which go to the graveyard (ie: mips) I usually put in notes (when/why/what to do instead) to conserve on the level of unnecessary chaos in our day :)  Thanks to COVID, there's plenty already!)

@Rich : Thank you!  I'm preparing a few RasPi4 devices this weekend, initially planning to test v12 armv7L and aarch64 (thus my noticing 7L "MIA") to see which would be best suited for the lab they're going to be part of and wanted to have the kernel source handy in case some tweaking was needed.
Code: [Select]
(2) PiZero Controllers (DHCP/DNS Primary/Secondary)
  Controlling (3) 8ch Relay modules to power the Pis and (1) 4ch Relay for the PSUs
  Powered by (5) 14A PSU (one 24/7, the others relay controlled)
(24) RasPi2
(4) RasPi3 First Gen
(4) RasPi4
-- All running TCL --
I'll ship in photos when she's finished; looks kind'a cute!

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11316
Re: piCore Extension Request
« Reply #31 on: January 06, 2021, 08:58:12 PM »
Hi centralware
...  Dead, as in, no longer supported - today and future releases? ...

I believe this repo covers  armv7, armv7l, and armv7l+:
http://tinycorelinux.net/12.x/armv7/tcz/

The difference being in the kernel module extensions, for example:
Code: [Select]
alsa-modules-5.4.51-piCore-v7l.tcz
alsa-modules-5.4.51-piCore-v7l+.tcz
alsa-modules-5.4.51-piCore-v7.tcz

The  zip  file found here contains multiple kernels:
http://tinycorelinux.net/12.x/armv7/releases/RPi/

Offline CentralWare

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 661
Re: piCore Extension Request
« Reply #32 on: January 06, 2021, 11:15:45 PM »
@Rich : Thank you for the detailed information; our repo has been updated (and set to no longer look for v7*)