WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: issues with inital setup  (Read 40 times)

Online pixel

  • Newbie
  • *
  • Posts: 3
issues with inital setup
« on: July 23, 2024, 11:33:55 PM »
hello all. i am using an x64 uefi-only laptop and am trying to install tiny core linux in any way possible with my wifi. i've tried every iso file offered and only tinycorepure64 works, which leaves me stuck considering the install guide assumes im already connected to the internet, which i am not. the only tool that works in creating this bootable usb is etcher, which makes the usb read-only (i'm trying this on a mac), stopping me from adding the tcz files for the wifi extension i need. this whole thing sounds like a massive xy problem; all i want is an installation of tinycore, i don't care how. i'd appreciate anyone pointing me in the right direction :)

Offline mocore

  • Hero Member
  • *****
  • Posts: 524
  • ~.~
Re: issues with inital setup
« Reply #1 on: Today at 02:08:37 AM »
wrt
>my wifi.

---> if it is a router you can access , perhaps *you* can skip some hoop jumping and use a lan cable ? <---

>the only tool that works in creating this bootable usb is etcher

what else did you try ?

because ... afaik (apart from some boot loader/manager eg grub2 ,ect) no "tool" is required ...


Online pixel

  • Newbie
  • *
  • Posts: 3
Re: issues with inital setup
« Reply #2 on: Today at 11:07:57 AM »
sorry my post is kind of all over the place. anyhow, i've tried rufus with wine, diskutility, and unetbootin. i found a way to manually add the extensions by booting up my computer with the bootable usb, then ejecting the usb after tc is loaded and erasing and reformatting the thing to fat32, then readding the same files along with any extensions in cde/optional and editing the onboot.lst file. the issue with this is now i can't boot into the os again, so i have to keep my computer on and can't reboot. i have no clue if this is the correct way to do it. i dont have a lan cable available to use for a wired connection.

i've managed to add every tcz file listed on http://repo.tinycorelinux.net/15.x/x86_64/tcz/wifi.tcz.tree in an attempt to use wifi.tcz. weirdly enough, now my taskbar isn't showing and when i try booting up the wifi app from the click menu, it just displays a black screen which allows typing???

Online pixel

  • Newbie
  • *
  • Posts: 3
Re: issues with inital setup
« Reply #3 on: Today at 11:13:30 AM »
taskbar thing is just me being stupid, wbarconf fixes it.