WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problem starting TC (SIS with Xorg)  (Read 2199 times)

Offline CyberDE

  • Newbie
  • *
  • Posts: 7
Problem starting TC (SIS with Xorg)
« on: April 19, 2011, 08:45:45 PM »
When I try to access the desktop, then appear the prompt (tc @ box) in the international forum user "Onyarian" I recommended the command "tc @ box: ~ $ startx" but when I run the command all display the black screen are some rare colors for a while and left of tag at the prompt.
I tried to root but I get a terrible mistake that does not reach the screen to show it, I write what I can see on the screen:

(EE) SIS (0): Unable to map IO Partura. Invalid argument (22)
(EE) SIS (0 ):****************************************
(EE) SIS (0): ERROR:
(EE) SIS (0): Could not map MMIO area
(EE) SIS (0): END OF MESSAGE
(EE) SIS (0 ):****************************************
(EE) SIS (0 ):****************************************
(EE) SIS (0): ERROR:
(EE) SIS (0): SiSMapMem () failed
(EE) SIS (0): END OF MESSAGE
(EE) SIS (0 ):****************************************

Fatal server error:
AddScreen / ScreenInit failed for drive 0

Please consult the TinyCore Linux support
                   at www.tinycorelinux.com
 for help.
Please also check the log file at "/ var/log/Xorg.0.log" for Additional Information.

XIO: fatal IO error 104 (Connection reset by peer) on X server ": 0.0"
             after 0 requests (or Known processed) with 0 event Remaining.



This happened when I restart the PC abruptly (restart button).

Sorry if this poorly translated.

PD:There is a message like this but add it here because I think it is the right forum.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Problem starting TC
« Reply #1 on: April 19, 2011, 08:58:10 PM »
Topics regarding Extensions - i.e. Xorg*.tcz - should go into the TCE forum. 
TCB is for TC Base.

 ;)
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline gutmensch

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 605
  • I can make it disappear, have no fear!
    • remembrance blog
Re: Problem starting TC (SIS with Xorg)
« Reply #2 on: April 20, 2011, 03:46:51 AM »
Try to use /etc/X11/xorg.conf.vesa by copying it to /etc/X11/xorg.conf and backing it up. Then run startx again.

The error seems to be SIS driver / libpciaccess related but it's also reported at g00gl3...
If I seem unduly clear to you, you must have misunderstood what I said. (Alan Greenspan)