WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: OSS4.0 in TC 3.3  (Read 4909 times)

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: OSS4.0 in TC 3.3
« Reply #15 on: December 13, 2010, 05:08:18 PM »
Is plugNplay enabled in the BIOS?

Offline Hangard

  • Newbie
  • *
  • Posts: 6
Re: OSS4.0 in TC 3.3
« Reply #16 on: December 21, 2010, 09:09:45 AM »
 ;D Solved! Thanks to all of the super attention/suggestions of TC members!

Surely the Wiki is included in that.

Been a couple days, [I got 'the look'   ::) so I had to quit spending observable time on this] but here is what happened.

The ALSA wiki has a Thinkpad 600 article. http://alsa.opensrc.org/index.php/ThinkPad600
 and as suggestions posted here firstly states that quick boot has to be off.
I verified again, it was off in CMOS
Suggestion 2 - use PS2.exe, the dos configuration tool. ugh! don't have it.  But it makes sense to use it as the hardware was not seen in dmesg output and not module would activate.

I downloaded PS2.exe and it would not install using my Windows95 DOS boot CD.  Get this - my 4G partition was too big.   I got a boot disk of DOS 4.1 made a smaller partition, losing all of my TCE files, etc[oh well, life goes on] and installed PS2. 

Root cause found:  I had a DMA confilct. The sound needs 1 & 3  but 3 was used  by my infrared port.  So I disabled parallel and Infrared [I don't need 'em as I only want to record live voice from my mixer board]  which freed up the DMA.  I was unable to do this from CMOS as it is soo limited on this old machine.

I then specifically set the sound hardware to the following  Address 0x530,  IRQ=5 DMA1=1,  DMA2=3 Soundblaster port=0x220.

When I booted TC from live disk and inabled ALSA it had found and configured module snd_cs4236 - I have sound!!

Then I did a hard disk install following the procedure at the install link on the home page of TC.    Kernel panic! was the result.  Did you know there is a 'r' in  the line: initrd /boot/tinycore.gz  - sure enough that fixed my issue.  :-[

I did out of stubborness try the OSS drvers again.  I did not get them to work after about 45minutes so I went back to ALSA.  They work automatically.  It is just that the sounds are all muted and at 0 levels. - so once that is adjusted with the mixer all is well.  I can get CD's to play and my MP3 player in the line in works fine too. So I have a IBM 380Z that I can use to record live audio.

Now I just have to automate the mixer levels and find a recording package that is light enough to run on this meager hardware, none tried yet are working for me - but surely that is a topic of another post.

Thanks again for the posts, insights, time scratching your head, etc on my behalf.  Tiny Core sure has been a blast so far - and I have more to come.