WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problem with mysql (linuxthreads)  (Read 7086 times)

Offline archivista

  • Newbie
  • *
  • Posts: 8
Problem with mysql (linuxthreads)
« on: March 17, 2009, 07:59:36 PM »
I tried to install mysql 4.0.24, but got the following error when running ./confiugre script

checking "LinuxThreads"... "Not found"
configure: error: This is a linux system and Linuxthreads was not
found. On linux Linuxthreads should be used.  Please install Linuxthreads
(or a new glibc) and try again.  See the Installation chapter in the
Reference Manual for more information.

How can I solve this error? I tried to search about it and it looks like that glibc 2.3.6 has no linuxthreads. Is this correct?


Offline ^thehatsrule^

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 1726
Re: Problem with mysql (linuxthreads)
« Reply #1 on: March 17, 2009, 11:37:50 PM »
Could be related to this: http://bugs.mysql.com/bug.php?id=2173
Is there any reason why you are using this version?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10992
Re: Problem with mysql (linuxthreads)
« Reply #2 on: March 18, 2009, 01:05:14 PM »
Indeed; linuxthreads is a very old implementation, dropped right after glibc 2.3.6. And up to that version people could choose to use NPTL instead (we did too).
The only barriers that can stop you are the ones you create yourself.

Offline archivista

  • Newbie
  • *
  • Posts: 8
Re: Problem with mysql (linuxthreads)
« Reply #3 on: March 19, 2009, 03:58:59 PM »
We use this version in our products. But I'm open for any other release in the 4.x branch. Any recommendation?

Offline ^thehatsrule^

  • Retired Admins
  • Hero Member
  • *****
  • Posts: 1726
Re: Problem with mysql (linuxthreads)
« Reply #4 on: March 20, 2009, 05:51:32 PM »
Did you try the workaround for your 4.0.24 version?

It looks like 4.1 (as in the bug report) was the last 4.x release... probably still needs that workaround to build it for NPTL.