WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: IceWM odd behavior in TC3  (Read 1860 times)

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
IceWM odd behavior in TC3
« on: September 06, 2010, 02:01:13 PM »
When trying out IceWM at first I thought it was not working at all.  From a reboot, whenever the 'Start' menu button was clicked the only response was to display the window list as if that button had been clicked.  Indeed whichever button was operated the window list. was shown.

By sheer chance, the machine was rebooted without the noicons bootcode and Wbar was displayed.  Starting any of the apps via Wbar seems to kick IceWM into life as it then begins to work as expected.

IceWM was removed along with configuration  files I could find and FLWM reinstated which worked correctly. Reinstalling IceWM, the symptoms returned.

This is repeatable with the preferences file created by the default install, and also after the preferences file has been has been copied to the home dir and edited.
 

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: IceWM odd behavior in TC3
« Reply #1 on: September 13, 2010, 04:12:15 AM »
Update for TC3.1

As this is such an unusual event it was retested with the new release.  The symptoms remain exactly as reported in the opening post, however it has been narrowed down to occurring on two HP machines (dissimilar models).  On two other machines (both different manufacturers) IceWM works as expected.

The issue is consistent and repeatable:
  • Leave open a window (e.g. terminal) via Wbar=IceWM works OK
  • Do not open a window via Wbar=IceWM only displays the window list whatever is clicked
 

Just for clarity, this test was conducted on a reformatted USB flash device (i.e. all traces of previous TC installation removed) and the only extensions installed were kmaps and IceWM.  No dependencies were listed as missing.
 
« Last Edit: September 13, 2010, 08:14:23 AM by SamK »