WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: glib2  (Read 3761 times)

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
glib2
« on: January 24, 2009, 12:33:10 PM »
I was trying to compile libgsf-1.14.0  and got error message "no package glib2". I installed the glib2 tczl and dev packages, exported LD_LIBRARY_FLAGS,  etc, and even recompiled glib2 with no success. What am I doing wrong?? Thanks

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: glib2
« Reply #1 on: January 24, 2009, 12:40:58 PM »
libgsf is in the librsvg extension (not obvious from the name I know, but...)

You're perhaps missing "export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig"?

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: glib2
« Reply #2 on: January 24, 2009, 12:59:41 PM »
I tried exporting PKG_CONFIG_PATH and a few other flags to no avail. I'm curious why nothing worked.  Meanwhile, I'll check out librsvg.  Thanks