WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: cups, samba printing  (Read 17269 times)

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
cups, samba printing
« on: October 06, 2009, 03:12:03 PM »
All was working until some recent updates. Now:

errors  noted at the cups admin site:

Code: [Select]
Bad device-uri scheme "smb"!
 
Paused - "Backend /usr/local/lib/cups/backend/smb does not exist!"
After issuing smbd command from samba, I got a broke pipe error

I think I had recall having to place the smb file when configuring with puppy.                                                                    
« Last Edit: October 06, 2009, 03:15:28 PM by jpeters »

Offline perthie

  • Full Member
  • ***
  • Posts: 118
Re: cups, samba printing
« Reply #1 on: October 06, 2009, 03:20:47 PM »
The CUPS backend file /usr/local/lib/cups/backend/smb should be a symlink, typically to
/usr/local/bin/smbspool.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #2 on: October 06, 2009, 03:54:34 PM »
The CUPS backend file /usr/local/lib/cups/backend/smb should be a symlink, typically to
/usr/local/bin/smbspool.

Thanks..That was the link I needed for puppy config.  The printer now installs, but still having some issues:
Code: [Select]
Driver: HP Deskjet 940c Foomatic/hpijs, hpijs 2.8.12.26 (color, 2-sided printing
Connection:     smb://DESK/HP940c


printer HP940c is idle.  enabled since Tue Oct  6 12:42:24 2009
no system default destination

so nothing happens when I try to print, although it sees the printer ok:  
Code: [Select]
tc@box:~$ lpstat -p -d  
printer HP46082B is idle.  enabled since Tue Oct  6 11:55:32 2009

Cups admin no longer has a print test (that I could find, anyway).  





Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #3 on: October 06, 2009, 04:04:08 PM »
The CUPS backend file /usr/local/lib/cups/backend/smb should be a symlink, typically to
/usr/local/bin/smbspool.

Thanks..That was the link I needed for puppy config.  The printer now installs, but still having some issues:
Code: [Select]
Driver: HP Deskjet 940c Foomatic/hpijs, hpijs 2.8.12.26 (color, 2-sided printing
Connection:     smb://DESK/HP940c




printer HP940c is idle.  enabled since Tue Oct  6 12:42:24 2009
no system default destination

so nothing happens when I try to print, although it sees the printer ok:  
Code: [Select]
tc@box:~$ lpstat -p -d  
printer HP46082B is idle.  enabled since Tue Oct  6 11:55:32 2009


I get a "broken pipe" error when printing from geany.  
« Last Edit: October 06, 2009, 06:49:24 PM by jpeters »

Offline perthie

  • Full Member
  • ***
  • Posts: 118
Re: cups, samba printing
« Reply #4 on: October 06, 2009, 04:07:15 PM »
Which version of CUPS are you using?

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #5 on: October 06, 2009, 04:12:52 PM »
Which version of CUPS are you using?

Updated to 1.4.1, the previous version worked fine. (I've updated other things since using the printer, like dbus, etc.)
« Last Edit: October 06, 2009, 04:15:54 PM by jpeters »

Offline perthie

  • Full Member
  • ***
  • Posts: 118
Re: cups, samba printing
« Reply #6 on: October 06, 2009, 04:25:46 PM »
The CUPS 1.4 package is broken several ways. You are best to stay with 1.3.8. If you are now using TC 2.4, you can bring over the CUPS 1.3.8 tce package and get it to work fine. I converted mine to a tcz, just to be consistent.




Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #7 on: October 06, 2009, 05:30:49 PM »
I see that /usr/local/lib/cups/backend/smb is listed as a cups file, but doesn't load.   There's no longer
a /etc/init.d/cups file to start.  

edit: scheduler started when booting

doesn't except "export PRINTER commands   ( eg "PRINTER=HP940c",  "PRINTER=smb://smb://DESK/HP940c")  or lpoptions:

Code: [Select]
tc@box:~$ lpoptions -d HP940c            
lpoptions: Unknown printer or class!

edit: okay, able to export Printer  (needed to reinstall printer in cups).  Not getting "no destination" error anymore; but it's just hanging after issuing print command (getting closer).....
« Last Edit: October 06, 2009, 06:09:14 PM by jpeters »

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #8 on: October 06, 2009, 06:15:34 PM »
Looks like it's ready, but still not printing

Code: [Select]
tc@box:~$ lpoptions -d HP940c
auth-info-required=none copies=1 device-uri=smb://DESK/HP940c finishings=3 job-hold-until=no-hold
 job-priority=50 job-sheets=none,none marker-change-time=0 media=na_letter_8.5x11in
number-up=1 printer-commands=AutoConfigure,Clean,PrintSelfTestPage printer-info
printer-is-accepting-jobs=true printer-is-shared=true printer-location printer-make-and-model='HP
Deskjet 940c Foomatic/hpijs, hpijs 2.8.12.26' printer-state=3 printer-state-change-time=1254841449
printer-state-reasons=cups-missing-filter-warning printer-type=8425500
printer-uri-supported=ipp://localhost:631/printers/HP940c sides=one-sided
tc@box:~$ lp stats.txt
request id is HP940c-2 (1 file(s))
tc@box:~$ lpr  stats.txt
tc@box:~$

Cups printer  doesn't save after a boot, even with 
 etc/cups/printers.conf
 etc/cups/ppd/HP940c.ppd
 etc/cups/cupsd.conf

Bye.....
« Last Edit: October 06, 2009, 07:10:02 PM by jpeters »

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #9 on: October 06, 2009, 11:38:04 PM »
Loading -i -r  removes necessity of exporting PRINTER:
Code: [Select]
tc@box:~$ lpstat -d HP940c
system default destination: HP940c
HP940c-1                root              1024   Tue Oct  6 20:22:40 2009

This may all come down to permission errors. 

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: cups, samba printing
« Reply #10 on: October 07, 2009, 12:08:18 AM »
Quote
The CUPS backend file /usr/local/lib/cups/backend/smb should be a symlink, typically to
/usr/local/bin/smbspool.
Let me check when I get back home - the symlink should be there.

Quote
Cups admin no longer has a print test (that I could find, anyway).
It's in a drop-down box on the "printers" tab

Quote
The CUPS 1.4 package is broken several ways.
Since there are many ways to print, I cannot test them all, but it works for me. Aside from the samba symlink, are there other problems with the extension packaging or are you speaking of bugs in cups-1.4 as compared to cups-1.3?

Quote
Cups printer  doesn't save after a boot, even with
 etc/cups/printers.conf
 etc/cups/ppd/HP940c.ppd
 etc/cups/cupsd.conf

Your printer set-up may need an extra file, could you try from scratch, using "touch mymarker", set-up printer, "find yada yada" to see which files are added when you add a printer maybe?

Quote
Loading -i -r  removes necessity of exporting PRINTER:
Does it print now?

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #11 on: October 07, 2009, 12:38:44 AM »
I found the print test.
No, still not printing.  Curious, the HP printer driver doesn't show hp in the "Add Printer" drop down list
like it used to. I have to provide PPD file.

shows up as "stopped" in cups jobs; no reason.
Code: [Select]
tc@box:~$ lp stats.txt
request id is HP940c-1 (1 file(s))


Maybe /etc/printcap, although it should be generated by the printers.conf file.

New files:
/etc/printcap
/usr/local/etc/cups/printers.conf
/usr/local/etc/cups/ppd/HP940c.ppd
/var/spool/cups/tmp
/var/run/cups/certs/0
/var/log/cups/access_log
/var/log/cups/error_log
/var/cache/cups/HP940c.ipp
/var/cache/cups/ppds.dat

edit: still no printer in cups after reboot. (after adding /etc/printcap) . Don't think adding /var files
is appropriate.
« Last Edit: October 07, 2009, 12:47:48 AM by jpeters »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: cups, samba printing
« Reply #12 on: October 07, 2009, 03:37:58 AM »
I found the print test.
No, still not printing.  Curious, the HP printer driver doesn't show hp in the "Add Printer" drop down list
like it used to. I have to provide PPD file.

Are you using a usb connected printer? The reason I ask is that I saw somewhere that cups-1.4 had problems with some usb printers and you might need to "rmmod" the usblp module and then restart cups - you should then see your printer automatically.

Also, the cups-1.4 version of the extension does not contain foomatic-rip - it appears from posts above, you might be using a ppd that requires foomatic rip rather than choosing the "cups driver dynamic generation of the pdd" thing. If you set the logging to "debug" in cupsd.conf and restart cups, you will be able to see a lack of foomatic-rip error if this is the problem.

Did you try with hplip? My all-in-one hp printers will only work with hplip (the "hp" backend), so I cannot test the usb backend.
« Last Edit: October 07, 2009, 03:40:21 AM by Juanito »

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: cups, samba printing
« Reply #13 on: October 07, 2009, 04:16:27 AM »


Also, the cups-1.4 version of the extension does not contain foomatic-rip - it appears from posts above, you might be using a ppd that requires foomatic rip rather than choosing the "cups driver dynamic generation of the pdd" thing.
Did you try with hplip? My all-in-one hp printers will only work with hplip (the "hp" backend), so I cannot test the usb backend.

That's it, I'm using foomatic-rip, which used to work fine. I loaded the new drivers from the hplip extension, which appear in the drop-down menu. I selected HP deskjet 940c, and all looked good until I tried to test:
Code: [Select]
Print Test
unsupported format 'application/vnd.cups-banner'!

Okay, so I try to print from geany:
Code: [Select]
lpr: Unsupported format 'application/postscript'!

This looks okay
Code: [Select]
tc@box:~$ lpstat -d
system default destination: HP940c


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: cups, samba printing
« Reply #14 on: October 07, 2009, 04:27:40 AM »
Code: [Select]
Print Test
unsupported format 'application/vnd.cups-banner'!
I saw that once or twice and stopping/restarting cups made it go away.

With hplip, you may need to link /usr/local/etc/hp -> /etc/hp - it appears hplip doesn't like /usr/local.

Can you confirm you're using a usb printer?