Tiny Core Base > Raspberry Pi

tc noob trying to make dwm (picore14)


i have libXft-dev and freetype-dev installed, when compiling i get

--- Code: ---usr/local/include/Xft/Xft.h:39:10 fatal error: ft2build.h: No such file or directory
     39 | #include <ft2build.h>
--- End code ---

i looked, and do not see any freetype2 (lib- or -dev) in the repo. i tried to simply dd line 39, as a possible quick fix, but the file is read-only and su- got me a lecture on root/time.sh. what am i missing/is it just a missing package/included in another lib? :-[
assume i could dl it from github, but wished to ask before simply grabbing it from the web.

The freetype extension is freetype2.   The header you are looking for is in the -dev package  /usr/local/include/freetype2/ft2build.h

I would have to guess your build configuration is not setup corrrectly.

I also get the same error when I do the same thing.

--- Quote from: Rich on September 18, 2013, 03:46:01 PM ---Hi Misalf
You could try executing this from the command line first:

--- Code: ---export C_INCLUDE_PATH=/usr/local/include/freetype2
--- End code ---
More info can be found here:

--- End quote ---

If an app uses freetype, it should get the flags from pkg-config (pkg-config --cflags freetype2). Some distros install freetype differently so this is not needed and so such a build can accidentally work. Check your pkg-config returns the correct flags; if it does, then check how dwm's configure process checks for it. If it doesn't, you will need to add it, via env flags or configure flags.


[0] Message Index

Go to full version