Tiny Core Base > Raspberry Pi

Using a SPI connected SD Card breakout with Pi Zero 2 W

(1/2) > >>

Hey all,
I've been battling for the last day or so with trying to get a SPI SD card reader to work with a Pi Zero 2 W running PiCore 14.1 64bit. This is what I bought: https://www.ebay.co.uk/itm/256284946662

I have it hooked up to SPI1 on my Pi zero using GPIO 18 as the CS pin (I already tried SPI0, same results unless I was missing something), I've enabled SPI in the config.txt file, and I've added this line at the bottom of config.txt:

If I run dmesg | grep mmc I get this:

--- Code: ---[    2.936327] mmc-bcm2835 3f300000.mmcnr: mmc_debug:0 mmc_debug2:0
[    2.936359] mmc-bcm2835 3f300000.mmcnr: DMA channel allocated
[    3.013529] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[    3.077733] mmc0: host does not support reading read-only switch, assuming write-enable
[    3.082110] mmc0: new high speed SDXC card at address aaaa
[    3.083910] mmcblk0: mmc0:aaaa SD64G 59.5 GiB
[    3.089950]  mmcblk0: p1 p2
[    3.091039] mmcblk0: mmc0:aaaa SD64G 59.5 GiB (quirks 0x00004000)
[    3.099315] mmc1: new high speed SDIO card at address 0001
[    4.776725] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Quota mode: none.
[    4.782968] EXT4-fs (mmcblk0p2): unmounting filesystem.
[    4.828737] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Quota mode: none.
--- End code ---

As far as I can tell, mmc1 is my SD card, so it's seeing it. But if I ls /dev/ I only see mmcblk0 which is the built in SD card rather than my external one.

I've searched high and low to try and figure out what I'm missing but I'm not getting anywhere. Can anyone try point me in the right direction? What I ultimately want is to mount the external SD card so I can copy files from it (I only need it to be read only)

We probably don’t have the kernel drivers for that loaded, or in an extension.  Do you know what is needed for sdio?

Afraid not, it didn't come with any documentation either. I did try enabling the sdio overlay when testing, but it seemed worse as the wifi stopped working, bizarrely.

Hi eddible
Welcome to the forum.

This fellow claims his solution got it working:
Another member on that forum tried that solution and failed.

--- Quote from: eddible on May 13, 2024, 06:51:34 AM --- ... but it seemed worse as the wifi stopped working, bizarrely.
--- End quote ---
Confirmed here:

Thank you!

Okay I tried to generate the dtbo file, which was successful, added it to my config.txt but I get the same result. What I'm confused by is that I see the exact same output from dmesg as above, so it's almost like my changes to the config file aren't being processed perhaps? Is there a way to see errors, or otherwise confirm the dtoverlays are being loaded as expected?


[0] Message Index

[#] Next page

Go to full version