WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Firefox, http://............ with username/password does not work  (Read 410 times)

Offline abru

  • Newbie
  • *
  • Posts: 4
I have installed tinycore on my hard disk and have now encountered a problem with Firefox.
Tested with tinycore 32 and 64-bit, v15.0 version and Firefox 124.0.1 (32-bit) and Firefox 124.0.1 (64-bit)
Calling https://                                          works fine
Calling http:// with username/password     does not work
Example portainer:
   Error message: Failure Unable to retrieve user detail: Unauthorized
Example homebridge:
   Error message: Invalid Username or Password

When I start firefox in private mode (firefox_private), it works fine! Do you have an explanation for this?

Translated with DeepL.com (free version)

Offline abru

  • Newbie
  • *
  • Posts: 4
Re: Firefox, http://............ with username/password does not work
« Reply #1 on: April 01, 2024, 10:34:59 PM »
one more note.
when I start the system from the "CorePlus installation image" (CorePlus-current.iso) and install firefox,
then http://.......      with username/password works fine
when I start the system from the "CorePlus installation image", run tc-install for a frugal installation and install firefox,
then http://.......      with username/password no longer works , only via firefox_private

Offline abru

  • Newbie
  • *
  • Posts: 4
Re: Firefox, http://............ with username/password does not work
« Reply #2 on: April 05, 2024, 01:27:04 PM »
Hmm, i have now found the cause of the error. I use grub2 as bootloader and my entry looks like this:

menuentry "Start tinycore64 on device sda8 folder mac/tiny6401" {
    search --fs-uuid --set=root 523f3b41-85ff-4cf6-af51-a004d79e30fb
    linux /mac/tiny6401/boot/vmlinuz64 rw root=UUID=523f3b41-85ff-4cf6-af51-a004d79e30fb tce=UUID=523f3b41-85ff-4cf6-af51-a004d79e30fb/mac/tiny6401/tce tz=CEST-1
    initrd /mac/tiny6401/boot/corepure64.gz
}

The problem was the root keyword and after this change, it works perfectly!

menuentry "Start tinycore64 on device sda8 folder mac/tiny6401" {
    search --fs-uuid --set=root 523f3b41-85ff-4cf6-af51-a004d79e30fb
    linux /mac/tiny6401/boot/vmlinuz64 rw UUID=523f3b41-85ff-4cf6-af51-a004d79e30fb tce=UUID=523f3b41-85ff-4cf6-af51-a004d79e30fb/mac/tiny6401/tce tz=CEST-1
    initrd /mac/tiny6401/boot/corepure64.gz
}

« Last Edit: April 05, 2024, 01:40:10 PM by abru »

Offline patrikg

  • Wiki Author
  • Hero Member
  • *****
  • Posts: 673
Re: Firefox, http://............ with username/password does not work
« Reply #3 on: April 05, 2024, 02:20:54 PM »
Strange ??
After you booted up, you can look at the
Code: [Select]
cat /proc/cmdline
To see how the kernel command line args line being deployed with grub.
i think the search sets the root entry, so you should see maybe two entry's.

So you can maybe remove own your entry from the linux line.
« Last Edit: April 05, 2024, 02:28:22 PM by patrikg »